Cancel
Showing results for 
Search instead for 
Did you mean: 

Hole callout> threaded holes> THRU depth

Experimenter
Experimenter

Hello! 

My name is Tim Grant, I'm a 15 year machine designer, just started with NX 3 weeks ago (NX 9), and this is my first post.  Thanks for having me.

 

In a drawing I'm using the radial dimension> hole callout command to dimension threaded and counterbored holes in a simple part; please see attached file.  In the model the cbore hole Depth Limit is set to Through Body.  The threaded hole Depth Type is set to Full and Depth Limit is set to Through Body.  In the drawing the hole callout of the cbore displays "THRU" for the shaft diameter depth (as expected) but the depth for the threaded holes displays as the thickness dimension of the part (in this case 12.70mm) instead of "THRU".  How can I make the hole callout always display "THRU" for through-body threaded holes?  

 

Hole callout thread depth capture.PNG

 

Thanks very much,

Tim

 

2 REPLIES

Re: Hole callout> threaded holes> THRU depth

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello, and welcome to the community!

 

The dimension for your threaded hole is showing the depth of the thread itself, and not the depth of the hole. To fix this specific dimension, do the following:

  1. Double-click the dimension to begin the edit mode.
  2. In the onscreen edit box, in the lower right corner, click the Text Settings button. (It looks like a blue-colored A).
  3. In the Text Settings dialog, click the Hole Callout node.
  4. In the Parameters group, clear the Thread Size option (click the checked box)
  5. Click the box next to the Depth option to set it. Now the depth shows up in the dimension, but it's in the wrong place.
  6. With the Depth option highlighted (select it again if you have to), click the Move Down button once (it's the arrow down button on the right side of the dialog).
  7. Close the dialog, and look at your dimension. It should show the THRU extension correclty now.

 

Re: Hole callout> threaded holes> THRU depth

Experimenter
Experimenter

Fantastic!  That worked beautifully.  Thank you very much, DEckhoff!  I greatly appreciate it.