Showing results for 
Search instead for 
Do you mean 
Reply

How To Export PMI from NX10

I am having difficulty exporting PMI callouts from NX10. I have tried exporting as every file type but the closest I came was exporting as a DWG; it brought the lines but not the actually annotations I need with it. Any suggestions or advice?

5 REPLIES

Re: How To Export PMI from NX10

I can get it out with both JT and STEP. In the one image you see NX on the right and TC Vis on left that has the PMI in both of them. In the second image there is an option to turn on PMI for STEP export. 

 

TC Vis and NXTC Vis and NXSTEP export optionsSTEP export options

 

Hope this helps,

Scott

Re: How To Export PMI from NX10

I just tried using these setting and it still failed to bring the annotations along with it. I should add that I'm trying to bring it into Rhino v5.0; I have also tried bringing it into Solidworks; both have failed. 

 

When I try exporting from NX, depending on the settings used, I would get a message telling me that some selected objects could not be exported because they are linked to other objects; even though I exported absolutely everything in the part I was still missing the annotations. 

 

Any other suggestions or advice would be greatly appreciated.

Re: How To Export PMI from NX10

I seem to have figured this out on my own. I played with the View Dependent Edit settings to change Convert Dependency To Model. The PMI's have come through now.

 

 

Re: How To Export PMI from NX10

It sounds like you are not using PMI, but instead are trying to convert dimensions and annotation from a drawing into a model view and then export it?  The View Dependent Edit command is only available in the Drafting application.

 

If this is the case, then you are not creating valid PMI objects in your exported data.

Re: How To Export PMI from NX10

@DEckhoff @ScottFelber

 

I am also facing issue with it. When I export JT containing some PMI dimensions from NX (TC-NX integration with NX 10). JT is not showing any PMI when I opened it in native NX. Is there any preference/setting required to set in TC?

 

But when I export JT using native NX, it works fine.

Testing NX10 | NX11
Teamcenter 11.2 | TC Vis 11.3 | Active Workspace 3.2