Cancel
Showing results for 
Search instead for 
Did you mean: 

How could I restore Fonts?

Phenom
Phenom

I was working with some old NX files and then noticed when I create drawings the title block texts are all squares. Their fonts have changed to “Symbol” So I corrected them assigning a new font.

Now when I open newer files which I had created recently, all the texts including dimensions are squares. I believe somehow my default font type has disappeared (Couldn't find the default font= Arial Unicode MS) and it has changed to “Symbol” type.

Is there a way to restore my Fonts?

Michael Fernando


Die Designer
NX 11.0.2.7 + PDW

6 REPLIES

Re: How could I restore Fonts?

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
Take a look at "File > Utilities > Character Fonts". You'll find a list of fonts in your part file. You can replace fonts in the part that can no longer be found on your system.

Regards, Ben

Re: How could I restore Fonts?

Phenom
Phenom

Thanks for your reply Ben.

Do I have to do this to each and every drawing (which will be impossible)?

Do you have any idea of what had happened?

Should I use only NX fonts to avoid this kind of situation?   

Michael Fernando


Die Designer
NX 11.0.2.7 + PDW

Re: How could I restore Fonts?

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
Did you create this part?
Which version of NX was it created?
What font is your part looking for?

Also, take a look in your syslog for the following lines - what does yours show?

Unable to open character font file D:\SIEMENS\NX 10.0\ugii\ugfonts\xxxxx.xxx
Character font xxxxx was replaced by UGII_CHARACTER_FONT_DEFAULT

Ben

Re: How could I restore Fonts?

Phenom
Phenom

-My answers

 

Did you create this part -Yes (New parts now showing squares)
Which version of NX was it created? – NX10.0.3.5
What font is your part looking for? -Arial Unicode MS

Also, take a look in your syslog for the following lines - what does yours show?

Unable to open character font file D:\SIEMENS\NX 10.0\ugii\ugfonts\xxxxx.xxx
Character font xxxxx was replaced by UGII_CHARACTER_FONT_DEFAULT

-doesn’t show “Unable to open character font file…..”

Michael Fernando


Die Designer
NX 11.0.2.7 + PDW

Re: How could I restore Fonts?

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
Ah, so Arial Unicode MS is missing from your O/S?
Did you recently upgrade your O/S or start using a new workstation?

Microsoft included Arial Unicode MS with earlier versions of Office and paid a licensing fee to The Monotype Corporation, which is the copyright holder for the font. It appears that they no longer include that font with Office.
http://answers.microsoft.com/en-us/office/forum/office_365hp-word/arial-unicode-ms-font-missing/3d38...

The following page has a list of MS products that will install Arial Unicode MS. If you have one of these lying around you could install it to restore the font:
https://www.microsoft.com/typography/fonts/font.aspx?FMID=1081

Alternatively, if you have another computer you may be able to obtain a copy of that font from C:\Windows\Fonts

If every new file is showing squares then I suspect that you'll have to edit the list of character fonts in your NX templates to remove Arial Unicode MS (unless you're able to obtain a copy of the font).

Regards, Ben

Re: How could I restore Fonts?

Phenom
Phenom

I think the problem is fixed now. I contacted GTAC for another issue which they couldn’t reproduced. So we narrowed it down to that my  “NX100_user.dpv” is corrupted. (May be due to the old files I worked with)

Fixing this seems has corrected the fonts issue as well. (I need some time to test if it fixed the fonts issue.)

 

Here are the instructions I received from GTAC and would like to share:

 

Hi Micahel,

If you have a user specific issue, here are some steps to take:

  1. Exit NX.
  2. Go to the folder:  C:\Users\<<userid>>\AppData\Local\Siemens\NX
  3. Highlight the NX100 folder, ‘MB3àRename’.
  4. Rename this folder to:  NX100_old
  5. Re-start NX to see if it resolves the issue.

If it does resolve the issue, you can exit NX and gradually move some of the files from the “NX100_old” folder to the new “NX100” folder to see which file was causing the issue. I would move a couple files at a time, then re-start NX to see if the issue re-appears. This will help narrow down which file was the problem.

 

If renaming this folder does not resolve the issue, you can also delete the folder in the registry.

  1. Exit NX.
  2. Start regedit.
  3. Browse to:  'HKEY_CURRENT_USER-->Software-->Unigraphics Solutions-->NX’.
  4. Select the folder:  10.0
  5. MB3à
  6. Exit regedit.

Re-start NX to see if the resolved the issue.

Michael Fernando


Die Designer
NX 11.0.2.7 + PDW