Cancel
Showing results for 
Search instead for 
Did you mean: 

How to remove lines shown on facet body in drafting

Legend
Legend

Hello,

 

The picture below is a shaded view in drafting. The facet body (in blue) shows all of the lines that comprise it. I have not been able to find a way to turn this off all of these extra lines in the settings. When I export to a pdf for use as setup documentation when manufacturing, it comes out as one giant black mess that is not usable. 

 

Thanks!

 facet_body_in_drafting.pngNot desiredDesired Result.pngDesired

 

 

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM
11 REPLIES

Re: How to remove lines shown on facet body in drafting

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
Do you have the view "Representation" set to "Smart Lightweight" or "Exact"? You can find this by right clicking the shaded view, choose Settings and select "Configuration" under the Common node. If it's set to Smart Lightweight, change it to Exact and see if that helps.

Regards, Ben

Re: How to remove lines shown on facet body in drafting

Legend
Legend

It is set to exact. I tried Smart Lightweight and I also get the same result. 

 

I also tried setting the "wireframe color source" to "from face" and that still did not help. 

 

What I get when exporting a .pdf does not match what I see on screen. Not sure where the lines are coming from. Maybe some kind fo export setting?

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM

Re: How to remove lines shown on facet body in drafting

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

NX used to not show all the facet edges (NX7.5) but started doing so by NX10 (not sure where in-between the change was)

 

If you are showing an IPW for CAM setup documentation, this is a *big* PITA, as you noted, because something "recognizable" becomes a "black blob"

 

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Highlighted

Re: How to remove lines shown on facet body in drafting

Legend
Legend
Yes, other than talking a screenshot and adding a picture I do not see a workaround. I recently started using drafting for setup docs due to the fact that if I make a change to the setup, it automatically updates the docs (in most cases).

This make it unusable in some cases, since I must show represented stock before the operation.
Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM

Re: How to remove lines shown on facet body in drafting

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

It seems something similar was reported in PR 7786263.  The problem was resolved in NX 12.0.1.

However, this only resolves the issue for 'NX' facet bodies, not 'JT' facet bodies.  Originally I used the JT facet body type which continues to display the facet edges in the PDF when exported from NX 12.  Therefore, import the facet geometry using the "Facet Body Output Type: NX".  I can confirm that the facet edges that appear in an NX 11 exported PDF do not appear in the NX 12 exported PDF.

 

Therefore, to get this to work you will need to install NX 12.0.1 (when released).  You will also need to re-import your facet geometry into NX using the "NX" facet body type.

 

Regards, Ben

Re: How to remove lines shown on facet body in drafting

Legend
Legend

My facets are created by the manufacturing module within NX. I would assume these are the NX type then?

 

The properties>information did not give any clues as to what type it is. 

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM

Re: How to remove lines shown on facet body in drafting

Phenom
Phenom
I don't utilize shaded views at all and I'm currently using NX9 - but I have to ask, if things are the same in NX12 now, why in the world can you not automatically shut off the wireframe if you're placing a shaded view? Sure, if you want to see the black edges just like the model, I get it - but it seems pretty obvious to me that there might be a need to just shut all of that off. With all that said, yes, I know you can turn off Silhouettes, Smooth Edges, set Hidden Lines to Invisible, but that still leaves Visible Lines and there is NOT an Invisible choice for that. Seems like if things haven't changed, the simplest improvement would be to add an Invisible setting intended to only be used for shaded views....however, it would be best just to have a check box on the Shading setting that just turned off all edges period. I hope all of that makes sense.

Again, I'm using NX9 and only tested a solid body, but can the OP not open the View Settings, turn off all Silhouettes, Smooth Edges and set Hidden lines to invisible then do a View Dependent Edit and erase all the other edges?????
-Tim

Re: How to remove lines shown on facet body in drafting

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
why in the world can you not automatically shut off the wireframe if you're placing a shaded view?

Good question. The reason is that the facet edges are not visible in the drawing view, so the output should reflect what's in the view (wysiwyg).  Here's a side by side of the view in drafting (left) and the CGM Viewer (right).  I've highlighted the facet edges from the facet body that would be displayed if I exported the drawing to a PDF:

 

Screenshot - 1_12_2018 , 8_56_20 AM.png

Re: How to remove lines shown on facet body in drafting

Legend
Legend

I even tried selecting and deleting all lines as a "view dependent edit" and making wireframe color match the body. The result never changes. 

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM