Cancel
Showing results for 
Search instead for 
Did you mean: 

Import dwg

Valued Contributor
Valued Contributor

I have imported a layout from a dwg file but once I have the lines in NX I cant select them. Why this lines are different from the ones I can create in NX and how can I select them or use as auxiliary geometry to move or reference other elements?

10 REPLIES

Re: Import dwg

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Were they imported on to a layer that is visible only?  Use "Menu > Information > Object" and select the lines to determine which layer they are on and then use "Menu > Format > Layer Settings" to see if their layer is 'Visible Only'.

 

Can you upload a sample part file?

 

Regards, Ben

Re: Import dwg

Valued Contributor
Valued Contributor

I have repeated the proccess but copying the dwg file and erasing most of the data in order to protect intellectual property. Now I cant even see the lines in the graphic window. Please, find prt file attached.

Re: Import dwg

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Four line objects show up in the "non-timestamp geometry" folder, it appears that they may be outside of NX's model bounds. Below is the information taken from one of the lines:

 

line_error.PNG

Re: Import dwg

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

To determine the type of objects remaining in the file select "Menu > Information > Other > Layer":

1   Work              4          0    0, ALL
4 Line
2 Selectable 0 0 ALL, COMPRESORES_PI#0#2
3 Selectable 0 0 003 OCCULTA, ALL
4 Selectable 40 0 ALL, COMPRESORES_PI#0#3
40 Drafting Entity

"Drafting Entities" doesn't tell us much information and they're probably objects left behind when you deleted everything except the lines you were unable to select - Part Cleanup can remove these.  "File > Utilities > Part Cleanup > Cleanup Drafting Objects", removed the 40 Drafting Entities on layer 4.

From the Part Navigator with Timestamp Order disabled and with the Non-timestamp Geometry folder open, right click "Line x 4" and select the [ i ] icon for Object Information.  You'll get something like the following listed for each line:

Information Units    mm
Angle = 90.000000000
Length = 33163.466890019

Start Point XC = 2575737.732070700 X = 2575737.732070700
YC = -987886.302587220 Y = -987886.302587220
ZC = 0.000000000 Z = 0.000000000

End Point XC = 2575737.732070700 X = 2575737.732070700
YC = -954722.835697200 Y = -954722.835697200
ZC = 0.000000000 Z = 0.000000000

 

Note the Start Point and End Point coordinates.  These values are in millimeters and are greater than the (out-of-the-box) maximum bounding box defined in the NX Customer Defaults.  Select "File > Utilities > Customer Defaults > Gateway > Visualization > View/Screen tab".  Note the setting: Maximum Size for an Objects Bounding Box: 265000 mm.  Objects that fall outside this bounding box are not selectable/visible. 

I increased this value by adding a zero on the end.  On restarting NX and reopening the part I can now see and select the geometry.

 

Regards, Ben

Re: Import dwg

Pioneer
Pioneer

I seem to be having a similar problem with a drawing imported from I-deas.  Specifically, I can't select the lines when trying to "Move Object" or "Transform".  I have tried all of the suggestions above with no solution.

I have:

Made the view the active sketch view.

Added existing curves to the sketch.  When doing this everything turned to one color and acted like a symbol, which could not be smashed.

 

I checked to make sure that the layer was not "Visible Only"  For some reason, layer 204 and 205 have red check marks and the others do not.  Don't know what that means.  The entities I try to select for "Move Object" are on layer 204.

 

I expanded the maximum size of the bounding box by a factor of 10 with no help.  But I could not figure out how to check the start and end points of the lines.

 

Any other suggestions?

 

Thanks.

 

 

Re: Import dwg

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @DaveL3149,

 

The red check means that the layer is either visible (if red check is in Visible column) or visible and selectable (if red check is in Name column).  You need to have red check marks in the Name column if you want them to be selectable to move them.

 

I could not figure out how to check the start and end points of the lines.

You can check the coordinates of the curves by right clicking them and choosing Properties.  Select the General tan and then the Information icon.  If you can see them I suspect they're within the bounding box, so I wouldn't bother increasing the bounding box from it's default value. 

 

Any other suggestions?

Upload your part (if it contains no sensitive information) or contact GTAC.

 

Regards, Ben

Re: Import dwg

Valued Contributor
Valued Contributor

I have increased object bounding box size and the lines are now selectable. Thank you very much.

 

But in the proccess I have created a huge problem. When I changed the box size I had opened the layout assembly file. And now all the components in the assembly have disappear from graphic window, I still can see some geometry I have in the assembly file and I can see the componentes if I visualize them in an isolated window (I dont know how this new NX11.0.1 feature is called in english). I am trying to restore object bounding box size but I still cant see the components.

 

 

Re: Import dwg

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Try pressing the "home" button on your keyboard; it will orient the view to trimetric and, more importantly, reset the view clipping planes.

Re: Import dwg

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
It's possible that by displaying the objects far away from absolute that everything else has zoomed so far out, to fit the entire part in the display, that the components no longer display (or display as a pixel) - a consequence of increasing the max bounding box by a factor of 10. You could use layer management or the show/hide commands to turn off the display of object types until the components reappear. As cowski1 mentioned, it could also be the clipping planes - a Fit display would take care of that.

Regards, Ben