Cancel
Showing results for 
Search instead for 
Did you mean: 

Invalid name when exporting to dxf

Valued Contributor
Valued Contributor

I am trying to launch the DWG/DXF export wizard but it doesn't appear. Instead it said Invalid file name. This is my translation I am not using english language in NX. Anyone know how to solve it? Thank you

10 REPLIES

Re: Invalid name when exporting to dxf

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Does your file name have any special characters?  If it does, try again using letters and numbers only (e.g., abc123).
Does this happen for every file you try to export?  If it does you might want to consider contacting your local GTAC office.

Regards, Ben

Re: Invalid name when exporting to dxf

Valued Contributor
Valued Contributor

The file is ok because I can export it with other PC (Sorry I should have explained that before). I have checked the dxf/dwg translator options and in both PC are the same. I have tried rebooting the system...

Re: Invalid name when exporting to dxf

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
Search your NX log file for "Invalid filename" (Menu > Help > Log File). Is there an error code? Can you copy/paste it here?

Re: Invalid name when exporting to dxf

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Are you exporting it to the same folder on both PCs?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Invalid name when exporting to dxf

Valued Contributor
Valued Contributor

I have tried to export from the same file to same lan folder and to local folders, always with the same error in the first PC and always successfully in the second PC. I also have found that if I try to export form a TC drafting with the first PC then it can do the job. I am starting to suspect that the error happens since the first time this PC exported to dxf from TC.

This is the error code:

 

*** EXCEPTION: Error code  1020005 in line 69 of o:\ugnx1101\ip11\src\part\no\ind\System_OSFileSpecType.cxx

 

 

>>>> Error code  1020005 caught in file "DLGManager.cpp" at line number 505
>>>> Error code  1020005 caught in file "o:\ugnx1101\ip11\src\ugui\no\ind\dlg_callbacks.c" at line number 225
>>>> Error code  1020005 caught in file "o:\ugnx1101\ip11\src\ugui\no\ind\dlg_main.c" at line number 1727
>>>> Error code  1020005 caught in file "o:\ugnx1101\ip11\src\ugui\no\ind\mtlib.c" at line number 2947
>>>> Error code  1020005 caught in file "o:\ugnx1101\ip11\src\uifw\no\ind\uifw_definitions.c" at line number 4733
>>>> Error code  1020005 caught in file "o:\ugnx1101\ip11\src\uifw\no\ind\uifw_definitions.c" at line number 4877

Re: Invalid name when exporting to dxf

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
So this is an export from a Teamcenter managed session? You could try exiting NX and Teamcenter and clear out the user's cache.
Does the export work if you log into the workstation (i.e., Windows) as a different user and export?

Re: Invalid name when exporting to dxf

Valued Contributor
Valued Contributor

No, the error is from native sesion. In managed session I can export to dxf without any error.

 

I have tried with a different user and then it let me export Smiley Happy Thanks Ben, it looks like you are in the right way.

 

How can I delete NX temp files / user's cache? Will I lose any configuration?

Re: Invalid name when exporting to dxf

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

So a different user logged into the same workstation works?

Deleting the cache was only a suggestion if this was a TC managed session.  As it's native you could try exiting the NX session, delete the contents of the user's Temp directory, restart NX and attempt the export.

Re: Invalid name when exporting to dxf

Valued Contributor
Valued Contributor

I have replaced the DialogMemory.dlx and now the problem is solved. I have lost my dialog configuration though, but is not a big problem. Thank you very much Ben, you found what the problem was.