Cancel
Showing results for 
Search instead for 
Did you mean: 

MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward?

Valued Contributor
Valued Contributor

As you may have heard, MS has said that their "Service Pack Policy" applies to Visual Studio 2012 Update 4 -- that is, in mid-January 2015, support for VS 2012 Update 1 will end.  Will Siemens support U4 or some other MS-supported version of VS after MS ends support for U1?

http://support.microsoft.com/gp/lifeDevTool

8 REPLIES

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Siemens Phenom Siemens Phenom
Siemens Phenom

 

As you probably know, every release of NX is built with some particular version of the compiler, and for the best compatibility, we suggest that you use that same version to build your automation routines.  GTAC will continue to use the 2012 Studio with Update 1 for testing NX9 issues on Windows, but we recognize that customers will sometimes want to load updates as they become available.  I cannot point to any customer issues that could be definitely attributed to an update mismatch.  (I'm not saying it could never happen, but we have not seen it.)

 

Regards,

 

Steve

 

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Siemens Legend Siemens Legend
Siemens Legend

I think this thread is something like a request for an "official answer" for of what whas discussed in this thread.

I believe that this forum allows users post questions and get some hints, tips & tricks from other users (not only SPLM Employees Smiley Very Happy)... establishing a community that makes life easier by leveraging experiences from all over the world. This is a good thing. The answer to the request has already been given, and there are no other official documents I know that give some statments about future support.

 

So to get the "official answer" please ask GTAC. Dont't get me wrong the request is very valid but GTAC has lots more possibilities: Subject matter experts within GTAC as well as the direct contact to the responslible persons in the product development. The result may be an official anwer to you, but also a General Support Statement that helps other people having the same question as you do.

 

Regards, Johannes

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Valued Contributor
Valued Contributor

Whoops -- sorry.  I'm in my first month at my new job, and I didn't understand how things worked.  I'll ask GTAC.  Thanks.

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Creator
Creator

Hello Steve,

I am trying to convince my new company about how good is going with NXOpen. Can I go and get MS VisualStudio2015 for NX9? Do you have any explicit guideline suggestion? What's teh appropriate version of NX for VS2013 and VS2015? Do not want to scare them by purchasing useless IDE.

Thanks for your help.

Mauro

 

PS Say "Hi" to Amy (I am an old "friend" of you, GTAC people!)

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi Mauro,

 

Nice to hear from you!  NX9 and NX10 both require the MSVS 2012 Visual Studio, aka V11.

 

I believe that when NX11 comes out, it will require MSVS 2013, aka V12.

 

Best regards,

 

Steve

 

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Creator
Creator

Hello Steve.

That's bad for me: here they only got VS2010/13/15 for NX9. No luck for me?? Or do you know if there is any workaround?

 

Steve, one last question: can I contact you with my private email so you can get me my company ID for opening tickets @gtac?

 

Thanks again!

 

Mauro

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Siemens Phenom Siemens Phenom
Siemens Phenom

Mauro,

 

Sure - that's fine.  But you can probably find it quicker if you have a session of NX running.  Just select Help -> Log file, and when it opens, scroll down about half a page until you see a line like this:

 

************** Licensing Information **************

 

Right under that it should say "Server ID : ", and the number to the right is the number we need to open an IR.

 

Steve

Re: MS's support for VS 2012u1 will soon end. Will NXOpen for NX 9 support newer versions afterward

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

If you don't develop in C++, you are not bound to the VS version.

.NET allows you to use any VS release, since it only requires the correct .NET framework and there are no runtime library dependencies Smiley Wink

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.1, FBM, MRL 3.1.7 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk Testing: NX12.0 Preparing: NX12.0 | TcVis 11.4

Employees of the customers, together we are strong Smiley Wink
How to Get the Most from Your Signature in the Community
NX Customization - Best Practice Guide