Cancel
Showing results for 
Search instead for 
Did you mean: 

Mechatronics Concept Designer: Pick-and-Place with activating/deactivating Collision Body

Experimenter
Experimenter

Hello everybody,

I am facing a strange behavior in the MCD, when I try to implement a pick-and-place concept.

 

The structure is very simple:

The spindle has a collision body, which can be activated and deactivated using the MCD coupling in SIMIT. The dummy tools are derived from an assembly, which has been multiplied eight times.

 

2019-02-13 09_39_02-Window.png

 

Each tool has two Collision Sensors to detect whether it connects to the magazine or to the spindle. For this purpose, I created three operations. (Connect to Magazine/Spindle/none)

 

2019-02-13 09_37_16-Window.png2019-02-13 09_35_04-Window.png

The goal is, to activate the Collision Body in the spindle when the Z-axis reaches the correct position. Strangely, when I activate the Collision Body, the sensor does not seem to trigger, although the Collision Body is clearly in it.

When I leave the sensor area and enter again with an already activated Collision Body, the sensor triggers.

What am I doing wrong? (All sensors and Collision Bodies have the category 0)

 

(view in My Videos)

 

Is it not possible to trigger sensors when a collision body is activated in it? 

 

Thank you for your help,

Gianluca

1 REPLY 1

Re: Mechatronics Concept Designer: Pick-and-Place with activating/deactivating Collision Body

Experimenter
Experimenter

Hello again!

 

Unfortunately, I am still struggling with this problem.

 

Meanwhile, I found out that if I toggle the Collision Body the Collision Sensor is not triggered. But if I toggle the Collision Sensor instead, the collision is detected as soon as the sensor is re-activated.

 

Is this a bug?

 

Thank you for your help!