Cancel
Showing results for 
Search instead for 
Did you mean: 

Model component hidden on new drawing

Gears Phenom Gears Phenom
Gears Phenom

NX9 TC 10, using master model.

 

We have two sets of drawing formats, a set for NC, and a set for Indy.  If you create a model file, and then go file, new, and pick an Indy format, the model component comes in hidden.

ComponentHidden.jpg

If I do the exact same thing, but use one of the NC drawing formats, it is not hidden.  This seems to have started around January of this year, and I have no idea what may have triggered the change.  The only glaring difference I see, is that the Indy formats still use a "dummy part" in them to transfer attributes from the model to the drawing.  For the NC formats, I reworked them to use "DB_DWG_TEMPLATE_” , and got rid of the dummy file.  Note, the dummy part is not hidden in the drawing templates.

 

For the most part, they manage their own drawing templates, but I have been asked to figure out why the model component is being added as hidden.

 

Any thoughts?

-Dave
NX 11 | Teamcenter 11 | Windows 8.1
6 REPLIES

Re: Model component hidden on new drawing

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

What layer option is used when adding the component (work, original, or as specified)? Is the layer that the component ends up on visible in the template part?

Re: Model component hidden on new drawing

Gears Phenom Gears Phenom
Gears Phenom

If I just try to add a component, it says "work", but the model that is automatically added, is on "original".  I could see that being an issue, but 1 is my work layer, and my test model is on layer 1.

 

FWIW, their dummy part, is our model seed file.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Model component hidden on new drawing

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

Are all the layers visible (turned on) in the template part?

 

If the solid in the model file resides on a layer that is turned off in the template file, and the 'original' layer option is used, that could lead to some view discrepancies.

 

Probably a dumb question, but the component isn't marked as 'hidden' is it?

component_hidden.png

Re: Model component hidden on new drawing

Gears Phenom Gears Phenom
Gears Phenom

Not marked "hidden", I checked that.

 

going to log in as dba, and move the dummy to layer 1, and see if that helps.

 

edit:  no change by moving the dummy part to layer 1.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Model component hidden on new drawing

Siemens Phenom Siemens Phenom
Siemens Phenom
I've seen similar unexplainable show/hide behavior. Does it happen with all Indy format templates? How many are there?
As a test, load one of the Indy templates in NX and select Ctrl+W (Show and Hide). At the top of the dialog for "All" select "Hide (-)" then select "Show (+)". Save the template and see if it works.

Regards, Ben

Re: Model component hidden on new drawing

Gears Phenom Gears Phenom
Gears Phenom

Yes, all 8 of the Indy formats.

 

I will give that a test.

 

Tested:  No change in behavior.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1