cancel
Showing results for 
Search instead for 
Did you mean: 

NX 10 decimal cases

Experimenter
Experimenter

Hi! I am using NX 10.0.3.5 and I would to know if it is possible and how to change the user default values to set the dimensional constraints to 3 decimal cases as well as the drafting decimals (see pictures below).

 

I have found some solutions here on the forum but they only work for the current session or each constraint!

 

Thank you!!!

 

sketch.PNGdrafting.PNG

 

 

7 REPLIES

Re: NX 10 decimal cases

Phenom
Phenom

Did you set it in the customer defaults, and then re-save every drawing template, and model seed file, after applying the updated customer defaults to the annotation preferences?

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: NX 10 decimal cases

Experimenter
Experimenter

Hi DaveK!

 

First of all thanks for the reply.

 

Well, how do i change it in the "Customer Defaults", I have looked for it but I can't find it. And then I need to re-save every drawing template and model seed file... How do you do that?

 

Thanks again!

Re: NX 10 decimal cases

Phenom
Phenom

In NX 9, and I presume NX10, you would go to File, Utilities, Customer Defaults.  Then Drafting, Annotation, and the Dimensions tab.  You can pick your decimal places there.  Also note, you can do this for user, Group, or Site level, depending on what you have permissions for, and who you want to be affected by the change.

 

Do the same for PMI, under PMI, GD&T Tolerance.

 

Save the settings, and exit NX.

 

Restart NX, and open your model seed file, go to File, All Preferences, Drafting Preferences.  At the lower right corner change the Settings Source to Customer Defaults.  Then hit the button below it to Load from Settings Source.  Save the file.

 

Repeat for any other model seed files, and drawing formats.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: NX 10 decimal cases

Experimenter
Experimenter

Hi Dave,

 

I have look to what you said: " File, Utilities, Customer Defaults.  Then Drafting, Annotation, and the Dimensions tab." However I cannot find it.

 

In Nx I only have these options (sorry for being in french):Capturar.PNG

 

I saw a video on youtube with NX10 where they show how to change the number of decimal places and in the video they had the options you mention but I don't know why I dont have them, maybe it is a problem of my licence or permissions.

 

However, I could do what you said: "Do the same for PMI, under PMI, GD&T Tolerance."

 

But, I could not do the step: "File, All Preferences, Drafting Preferences.  At the lower right corner change the Settings Source to Customer Defaults.  Then hit the button below it to Load from Settings Source.  Save the file." When I try to save the option it always jumps back to "Pereferences".Capturar.PNG

 

Thanks for the help!

Re: NX 10 decimal cases

Honored Contributor
Honored Contributor

In NX 10, you must customize the drafting standard to change the number of decimal places in a dimension. In customer defaults go to drafting -> general/setup -> standard and press the customize standard button; a new dialog will open. Go to dimension -> text -> units and change the decimal places option as desired.

Re: NX 10 decimal cases

Experimenter
Experimenter

Hi cowski 1,

 

Actually I had already tried yor solution before and it did not work. I changed the number of decimal places and restart NX and nothin...still the same number of decimal places. Do you have to do something after that?

 

Thanks!!!

Capturar.PNG

Re: NX 10 decimal cases

Honored Contributor
Honored Contributor

You will need to update your template files as outlined by @DaveK. Before doing all that work, you can verify your new settings by creating a new "blank" file (file -> new -> choose the "blank" template). Create an object in this new file and test the new drafting settings. Verify the settings work as desired before updating your template parts.