Cancel
Showing results for 
Search instead for 
Did you mean: 

NX 10 drafting view problem

Experimenter
Experimenter

I cannot use the View Creation Wizard View Creation Wizardand Base View command in NX 10.  The computer uses Windows 10.  When I select the View Creation Wizard button or the Base View button I get this message:

"An attempt was made to use an invalid or deleted attribute id".  Any help would be appreciated.

8 REPLIES

Re: NX 10 drafting view problem

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Are you making a master model view (part and drawing separated files) or is the drawing in the part file?

 

Can you try to perform a part cleanup.


Ruud van den Brand
Pre-sales NX CAD
cards PLM Solutions

Re: NX 10 drafting view problem

@quigkevin,

Is this issue part specific? Was this working earlier?

I think part might have become corrupt. So while trying to place view, NX is giving error. An issue might get resolved after part cleanup, as asked by Ruud van den Brand.

 

Anyway it seems issue to me, so you can report IR on GTAC page.

 

Regards,

Samadhan

Re: NX 10 drafting view problem

Experimenter
Experimenter

It is a master model view.  I tried a part cleanup, but I still get the same "An attempt was made..." message when I try to use the view creation wizard or base view commands.  I should add that this part was created in Windows 7 but I was upgraded (is that the right word?) to Windows 10 yesterday.  Maybe this has something to do with the problem.

Re: NX 10 drafting view problem

@quigkevin,

 

I assume this issue occurs with that part only. As far I know, it should not matter where the part was saved and now where it is opened. 

You can try deleting some geometry from the part to figure out which features are causing issue.

 

Thanks,

Samadhan

Re: NX 10 drafting view problem

Experimenter
Experimenter

I tried creating a new part and bringing it into a new drawing but I get the same message (An attempt was made to use an invalid or deleted attribute id") and can't create the drawing view.

Re: NX 10 drafting view problem

Then it seems that NX might not be properly installed. If there is error for this functionality only, then I think you should contact to GTAC. Else see if installation is done correctly. 

 

Thanks,

Samadhan

Re: NX 10 drafting view problem

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @quigkevin,


@quigkevin wrote:

It is a master model view.  I tried a part cleanup, but I still get the same "An attempt was made..." message when I try to use the view creation wizard or base view commands.  I should add that this part was created in Windows 7 but I was upgraded (is that the right word?) to Windows 10 yesterday.  Maybe this has something to do with the problem.


In this case windows version should not be the problem. As error is reproducible with new parts also, please open IR to GTAC with necessary part, log files etc.

Reproduce the error and use File > Help > Generate Support Logs for IR/PR to collect the logs.

 

Are you using NX10 with latest MR/MP ?

Regards,
Ganesh

Re: NX 10 drafting view problem

Valued Contributor
Valued Contributor

try opening the drafting sheet, structure only.

Run part clean up, then try adding view.