Cancel
Showing results for 
Search instead for 
Did you mean: 

NX 11 Large sketch settings

Experimenter
Experimenter

Hi,

 

I am running into a problem where sketchs become large enough to where the large sketch settings apply.  At that point the "create inferred constraints" setting is turned off.  Problem is that you have to continouly turn it back on.  IE, i want to add a profile, open sketch (in task enviroment), click CIC (create inferred contraints button) or click checkbox in sketch settings tab, then click profile button and it is disabled there also, so click CIC button again, then draw geometry.  But now after drawing said geometry, the CIC option has been disabled once again.   Every time i want to create a new curve while still in the sketch editor task enviroment, i i have re-click the CIC after pressing the desired curve button (ie profile, rect., circle, trim mirror ect...)

 

This is extremely annoying and makes editing these sketch very tedious.  Is there anyway to turn off the large sketch optimization settings in the customer defaults?

6 REPLIES

Re: NX 11 Large sketch settings

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @st_hsu,

 

Did you choose "Don't display this message again" on the Large Sketch Performance dialog?

 

Screenshot - 8_28_2017 , 2_29_43 PM.png

 

If you did, in the background, each time your sketch invokes this dialog it's remembering what you selected.  Thus, if you chose "Yes" to turn off the settings, then NX will continue to turn them off without you having to interact with the dialog.  To reset this dialog you will have to select "Menu > Preferences > User Interface" and select Option to display the 'Reset "Don't display this message again"' icon.  Once you've restored the Large Sketch Performance dialog you should choose "No" if you don't want these settings turned off.  Note that if you do choose "Yes" without checking the "Don't display this message again" checkbox, the dialog will reappear in a new session.

There are no customer defaults or variables that control this dialog.  Until the interaction is improved, if you want to keep these settings on check the "Don't display this message again" checkbox and choose "No".  Alternatively create sketches with less geometry Smiley Wink

For the record, I had 82 curves, 48 dimensions and 40 constraints before the dialog was raised.

 

Regards, Ben

Re: NX 11 Large sketch settings

Experimenter
Experimenter

Thanks you so much... That fixed it.  I must of checked the box and clicked yes without thinking about it or realizing what it would do. I appreciate the help

Re: NX 11 Large sketch settings

Builder
Builder

Hello@BenBroad,

 

Fully agreed, with this option you will increase performance of large sketch,

 

but if I will turn off this option, then automatic constraints,auto dimension etc option will deactivate automatically,,

 

but if we want also constraints, auto dimension should be work in large sketch,,

 

is there any option or provision

 

 

appreciate your help 

Warm Regards
Thomas Roman
Machine Designer

Re: NX 11 Large sketch settings

Siemens Phenom Siemens Phenom
Siemens Phenom
As I mentioned above, there are no customer defaults or variables that control this behavior. If you want to see improvements to the functionality please submit your enhancements via GTAC.

Re: NX 11 Large sketch settings

Experimenter
Experimenter

Thank you so much.  I can't imagine why anyone would ever want thos settings under the "yes" option.

Re: NX 11 Large sketch settings

Phenom
Phenom
IF you are working with a lot of 2D data you might be more interested in using NX Layout! It's designed for working with 2D layout designs and pushing to 3D and assembly construction.
Right tool for the right job.