Cancel
Showing results for 
Search instead for 
Did you mean: 

NX 9 drafting issue- view rendering

Creator
Creator

When placing a view on the drawing NX 9 is ommiting a silloette of a face that was generated from a subtracted sweep tool. This did not happen in NX 7.5 and I am hoping for a fix. 

All my prefernces are set the same as NX 7.5 were.

19 REPLIES

Re: NX 9 drafting issue- view rendering

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

It may be a geometry error. To check, use the "examine geometry" command.

 

In the model file, use the examine geometry command; check all the body and face checks then window around the body to select everything (body, faces, & edges). It needs to pass the "body consistency" and "face self-intersection" tests. Strange things can happen in the model or drawing if it does not pass these tests.

Re: NX 9 drafting issue- view rendering

Creator
Creator

Good check.

Just checked it and had nothing horrible to report. I even went and removed the blends attached to the area that is being ommited. Still same result.

Re: NX 9 drafting issue- view rendering

Siemens Phenom Siemens Phenom
Siemens Phenom

Are you placing the view as a Smart Lightweight view or as an Exact view? You can tell which type you're using by checking the Common-->Configuration node-->Format group-->Representation option in the Style dialog box for the view.  If you're using a Smart Lightweight representation, you may need to set other options for the view. .

 

Re: NX 9 drafting issue- view rendering

Creator
Creator

It is set to exact.

thank you

Re: NX 9 drafting issue- view rendering

Siemens Phenom Siemens Phenom
Siemens Phenom

One thing you might want to try is to set the Representation option to Exact (Pre-NX 8.5).  If you don't see Exact (Pre-NX 8.5) as an available option, do this:

 

  1. Open the Customer Defaults dialog box.
  2. Select the Drafting->View node.
  3. On the General tab, set the Enable Exact (Pre-NX 8.5) Views option.
  4. Click OK and then restart NX. 

Now create your view and make sure to set the Representation option to Exact (Pre-NX 8.5) before placing the view. You have to set this option before you place the view because you can't convert an existing view.

Re: NX 9 drafting issue- view rendering

Siemens Phenom Siemens Phenom
Siemens Phenom
Is this an assembly or a piece part?
If it's a piece part are there multiple bodies?
Do you have interfering bodies?
What happens if you turn off hidden line rendering in the view settings?
Can you provide the part?

Regards, Ben

Re: NX 9 drafting issue- view rendering

Gears Phenom Gears Phenom
Gears Phenom

Have you tried changing your view tolerance tighter.  Instead of .005 or so go to .0003.  See if this helps.

Re: NX 9 drafting issue- view rendering

Creator
Creator

It is a single component and it is not happening to just this part, it is happening to other drawings different faces.

When I turn off the hidden lines. nothing changes except I can see the lines that were previously hidden.

 

I am sorry I cannot provide the file because it is proprietary.

Re: NX 9 drafting issue- view rendering

Creator
Creator
Where do I check this?