Showing results for 
Search instead for 
Did you mean: 

NX11.0.1 start up problem

Valued Contributor
Valued Contributor



When I try to start i'm getting this problem:

1st error: The Program can't start because xercess314.dll is missing from your computer. try reinstalling the program to fix this problem.

2nd error: The procedure entry point ?CacheUserAtributesBasic@MethodicObject@OM@UGS@@UEAA?AVAttributeChangeResult@Attr@3@PEBV123@_N11PEAX@Z could not be located in the dynamic link library c:\Siemens\NX11.0\NXBIN\windowsui.dll


Does somebody know what is happening? It already worked after the update.


Grts Tom


Re: NX11.0.1 start up problem

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello @TomVC,


I have seen a similar issue once... Some processes where still running on that system. Altough NX (ugraf.exe), was no longer running apparently some files were still in use for some unknown reason.


The way to solve it... Reboot your system, do NOT start NX. Re-run the update so all files are copied again, and the missing/corrupted files are also overwritten. This will most likely solve the issue, and NX should run again.


A good check, is to look at the end of the update process if it gives a message on files it could not copy to the system. There should be no errors/warnings in the end.


I hope this helps.

Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: NX11.0.1 start up problem

Siemens Phenom Siemens Phenom
Siemens Phenom

Do you have environment variables set anywhere that could be pointing to older versions of NX?


For example:

UGII_3DCONNEXION_LIBRARY=C:\Program Files\Siemens\NX 9.0\ugalliance\vendor\startup\3DxNX.dll


If you can post a syslog (or send an IM) we might be able to get a better idea of the problem.


Regards, Ben