Showing results for 
Search instead for 
Do you mean 
Reply

NX9 move object issue

Hi All,
I have following issue with move object function.
Please check attached picture.
How to turn off all these visible planes?

Regards

PKey

 

 

10 REPLIES

Re: NX9 move object issue

Were the planes already visible prior to using the Move Object command? If so, prior to opening the Move Object command, right click on them and choose Hide if you don't want to see them. Otherwise we're going to need to know a little more information. For example, do they only appear when you open the Move Object command?

Regards, Ben

Re: NX9 move object issue

I've also experienced these "phantom planes" appearing. Sometimes they show up, most of the time they do not (for me, at least). Seems to be somewhat related to using the "dynamic" move option in conjunction with the "move parents" option; but it has never bothered me enough to try to track down the root cause...

Re: NX9 move object issue

Hi,

thank You for Your support.
Unfortunately there is no way to select and hide those planes.
They are visible only when preview is activaded. But without preview it much more difficult to work...
I was tryiun got find any option to be able to turn them off but no results.

Problem is when I need to move items inside Part Navigator.
Unfortunately most of time I need to work in Part Navigator...

Please check picture in attachment. 5 items are selected. I can't see anything except those planes...

Sorry for my english.

Regards

Przemek

Re: NX9 move object issue

I see the issue now - through NX11. You can easily reproduce it just by selecting a Datum CSYS when using Move Object. The datums that highlight are the datums of the Datum CSYS feature, and in your case they're displaying because you likely have many Datum CSYS features that are parents of your currently selected geometry. I've contacted development to see if anything can be done to disable this display 'feature'. This behavior has been in the NX since at least NX6.

Regards, Ben

Re: NX9 move object issue

I don't think that visible datums are the datums of the Datum CSYS feature.
Datums of the Datum CSYS feature are small and don't disturb so much. Additionaly I can move them the to differrent layer and problem solved.
Please compare two new pictures to see differences between datums of the Datum CSYS feature and datums which are disturbing me(big yellow ones).
This is clear that those big yellow datumpl/planes are somehow connected with Datum CSYS, but they are not created by me. They just appears during using move object command.
Sometimas they are very small, sometimes very big (see first picture screenshot.513).
There is now way to selecte them to hide.

 

Regards

 

Przemek

Re: NX9 move object issue

Per development, the only way to prevent the datums from displaying is to turn off the preview. The suggestion was to uncheck "Move Parents" until you're ready to commit to the Move, then check it on again prior to hitting Apply or OK.

Regards, Ben

Re: NX9 move object issue

I'm wondering if you are using the correct move function...are you trying move components?

Re: NX9 move object issue

Nothing to do with moving components. The display issue occurs when the object being moved is associated to a Datum CSYS and the Move Parents and Preview checkboxes are enabled. It's by design. Workaround is to uncheck Move Parents until the object(s) has been moved and then check it on and Apply/OK.

Re: NX9 move object issue

OK. I was just curious since it looked like the whole assembly was active in the image that was provided.

I've seen people move sketches and solid bodies around because they thought working in assemblies was "difficult". Just wanted to be sure.