Cancel
Showing results for 
Search instead for 
Did you mean: 

Nothing showing in modeling app of a drawing

Gears Phenom Gears Phenom
Gears Phenom

I have a user at another facility, that has a model and drawing (msster model).  When in the model file, you see the solid part.  When in the drawing, but the application is modeling, you don't see anytyhing.  Switch to the drawing application, and you can add views from the model, but you don't see anything in views added from the drawing (makes sense, since you don't see anything in modeling).

 

Now, I did notice that in the assembly navigator, the icon for the model, is different for this file, than ones I have done.

 

Any thoughts on what was done, to create this?

 

FunkyDrawing.jpgStrange IconNormalDrawing.JPGExpected Icon

-Dave
NX 11 | Teamcenter 11 | Windows 8.1
20 REPLIES

Re: Nothing showing in modeling app of a drawing

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

The "strange icon" (yellow cube on top of a title block) means that you have added a view from another part. These are also known as drafting components. When you add a base view to a drawing, you have the option to choose which part to add the views from (OOTB settings defaults to the model file if you are doing a master model drawing). There is an option in customer defaults to show/hide the drafting component icon for master model drawings.

Re: Nothing showing in modeling app of a drawing

Gears Phenom Gears Phenom
Gears Phenom

Right now our default is teh OOTB setting, so both drawings had the views added from the model.

 

Submitted an IR, and so far GTAC is confused too.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Nothing showing in modeling app of a drawing

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

Drafting components do tend to confuse things. However, I'm not sure why GTAC is confused on this. Unless I miss my guess, someone created the Mk1 drawing file and added a view in the drawing without ever adding the Mk1 model as a component. Whoever created the C14 drawing added the model as a component before doing anything else.

Re: Nothing showing in modeling app of a drawing

Gears Phenom Gears Phenom
Gears Phenom

Ah, that could be...I never encountered a drawing with views from a model that was not a component within the drawing.   This is a new user, so who knows.

 

Do you recall where that setting in the customer defaults is for using views from the drawing, or the model?

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Nothing showing in modeling app of a drawing

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

The customer default option doesn't prevent the user from creating drafting components (adding views from other files). All it does is determine if the "drafting component" icon is shown for master model drawings or not...

Re: Nothing showing in modeling app of a drawing

Siemens Phenom Siemens Phenom
Siemens Phenom
Have the user select "File > New", select the Drawing tab and see what is set for Relationship. I suspect it was set to Stand-alone Part while the master model was loaded in the session. If the user had created a drawing this way, and then inserted a Base View from the master model, it would have created the structure shown in your first screen shot. If this is what happened, have the user change the Relationship to "Reference Existing Part" and make sure that the "Part to create a drawing of" (at the bottom of the dialog) is correct.

Regards, Ben

Re: Nothing showing in modeling app of a drawing

Gears Phenom Gears Phenom
Gears Phenom

I realize that, I was trying to check if our defalt is to pull views from the model, or from the drawing.  We have had some discussion on which it should be, with OOTB being from the model.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Nothing showing in modeling app of a drawing

Gears Phenom Gears Phenom
Gears Phenom

@BenBroad the only reference to Relationship I see, is "specification".  Is there a way to change this on the fly?

DraftingTab.JPG

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Nothing showing in modeling app of a drawing

Siemens Phenom Siemens Phenom
Siemens Phenom

Only if you enable blank templates (see attached image).

 

You can change the relation in the pax file:

 

  <PaletteEntry id="d1">
    <References/>
    <Presentation name="A - Size" description="Creates 8.5in x 11in size drawing" tooltip="This NX template example creates an A size drawing that references an existing model.">
        <PreviewImage type="UGPart" location="@DB/Drawing-A-Size-template/A"/>
    </Presentation>
    <ObjectData class="DrawingTemplate">
        <TemplateFileType>none</TemplateFileType>
        <Filename>@DB/Drawing-A-Size-template/A</Filename>
        <Units>English</Units>
        <UsesMasterModel>Yes</UsesMasterModel>
        <ItemType>Item</ItemType>
        <RelationType>specification</RelationType>
    </ObjectData>
  </PaletteEntry>

 

Regards, Ben