Cancel
Showing results for 
Search instead for 
Did you mean: 

Part families not working

Genius
Genius

Has anyone else had this problem?  For months, I've been able to work with part families, create new parts from the part families and modify/update parts.  Everything seemed to be working smoothly until I recently hit the "Edit Spreadsheet" button in the Part Families pop-up window and get a message stating "Failed to connect to Excel events".  

 

I don't think any changes have been made to NX or any other system settings and I have no idea why this doesn't work.  All I know is that now I can't work with the part families.  Does anyone have any recommendations?  I can work in Excel for other tasks, but I can't get to it from NX.  

 

Is there a way to work in the part families to create new parts and update existing parts without using Excel?  Thanks

9 REPLIES

Re: Part families not working

Siemens Phenom Siemens Phenom
Siemens Phenom

Check whether 'Ug' add in is active under the Add-Ins of the Excel Options. 

ugexcel.PNG

 

If not, Click on 'Go' button next to Manage Excel Add-ins and check 'Ug', OK. You should be able to launch spreadsheet.ugexcel1.PNG

 ugexcel2.PNG

 

Re: Part families not working

Genius
Genius

That worked! I've been fighting this for a few days now and you solved it with one reply.  Thanks for the information and the detailed response.  Much appreciated!  (I will be sharing this info with our helpdesk.)  Smiley Surprised)

Re: Part families not working

Experimenter
Experimenter

Hello Ganesh 

 

As i am also  facing the same issue , i am not to create part families , getting an error as "error recovery completed for the following error:Internal error" onces i hit Create option. 

 

I Also  checked with UG add in , it is active under the Add-Ins of Excel options , still i am not able to create part families 

 

So is this something where you can help ?

 

Thank you.

 

 

Re: Part families not working

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Ajinkya1,

Could you please provide some more details. What is the version of NX along with MR/MP? Is it native or managed NX? Is it reproducible on other machine also?

Re: Part families not working

Experimenter
Experimenter

YES , 

 

I am using NX8.5.3.3MP11,16NOV15

 

Problem is with both Native And managed NX

 

 

Re: Part families not working

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Also, what version of Excel are you using? NX 8.5 might not work with newer versions of Excel.

Re: Part families not working

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

For your Excel version - is it the 32 or 64 bit version? (only NX12.something supports 64 bit Excel)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Part families not working

Genius
Genius

Hello,  After doing the recommended fix, I was able to work with part families for quite awhile.  Unfortunately, one day it just quit and I couldn't access Excel anymore or work with the part families.  I tried the fix, again, but it didn't work.  I had to contact Siemens GTAC support and here's what was recommended.  This fix worked for me.

1. If Foxit PDf Reader is installed:

- Uninstall Foxit.
- Reboot.

2. Ensure that the Ug Add-in is listed and checked in Excel (and not disabled).

1) Excel: File > Options > Add-Ins
Ug should be listed.

2) Manage: Excel Add-ins > Go
Ug add-in should be checked.

3. Ensure that the path for Ug.xla is added to the Excel Trust Center Settings.

1) Excel: File > Options > Trust Center > Trust Center Settings

2) If path to Ug.xla is not listed:

Select "Add new location... > Browse" and browse to the NX install directory that contains the
ug.xla (e.g., C:\Program Files\Siemens\NX 10.0\UGII) > OK > OK > OK > Exit Excel

4. Restart NX, create a new part and select Menu > Tools > Spreadsheet

5. Confirm that Excel now starts.

6. (Optional) Reinstall Foxit but ensure the Excel plugin is UNCHECKED so it does not conflict with the UG Add-in
in Excel.

   

Re: Part families not working

Experimenter
Experimenter
Yes ,correct it is not working with Excel 2016,install Excel2010
version,working fine now.