Cancel
Showing results for 
Search instead for 
Did you mean: 

Part families not working

Valued Contributor
Valued Contributor

Has anyone else had this problem?  For months, I've been able to work with part families, create new parts from the part families and modify/update parts.  Everything seemed to be working smoothly until I recently hit the "Edit Spreadsheet" button in the Part Families pop-up window and get a message stating "Failed to connect to Excel events".  

 

I don't think any changes have been made to NX or any other system settings and I have no idea why this doesn't work.  All I know is that now I can't work with the part families.  Does anyone have any recommendations?  I can work in Excel for other tasks, but I can't get to it from NX.  

 

Is there a way to work in the part families to create new parts and update existing parts without using Excel?  Thanks

2 REPLIES

Re: Part families not working

Siemens Phenom Siemens Phenom
Siemens Phenom

Check whether 'Ug' add in is active under the Add-Ins of the Excel Options. 

ugexcel.PNG

 

If not, Click on 'Go' button next to Manage Excel Add-ins and check 'Ug', OK. You should be able to launch spreadsheet.ugexcel1.PNG

 ugexcel2.PNG

 

Re: Part families not working

Valued Contributor
Valued Contributor

That worked! I've been fighting this for a few days now and you solved it with one reply.  Thanks for the information and the detailed response.  Much appreciated!  (I will be sharing this info with our helpdesk.)  Smiley Surprised)