Cancel
Showing results for 
Search instead for 
Did you mean: 

Parts lists have no effect.

Pioneer
Pioneer

HI all

I have a big trouble.

Parts lists can not be edited and can not be moved, has always been a fixed position.
Editing level does not have any effect.

(view in My Videos)

10 REPLIES

Re: Parts lists have no effect.

Valued Contributor
Valued Contributor

Change The origin with Origin Tool could help. See the video.

Re: Parts lists have no effect.

Pioneer
Pioneer

HI  Radim_m

 

thans you

Re: Parts lists have no effect.

Pioneer
Pioneer

HI Radim_m  

Why is my line list only one line, I have a lot of components, but will not show in parts list.
The material will not be filled in automatically.

partslist.jpg

Re: Parts lists have no effect.

Valued Contributor
Valued Contributor

I am not sure about this one. It must be something in the setting. If I delete your table with its problems and make new one, everything works fine, even moving the table without changing origin. I was checking the setting, but didn´t find anything. Smiley Frustrated

Re: Parts lists have no effect.

Pioneer
Pioneer

HI Radim_M

  1. Is it a software problem? Is yours genuine?My version is NX11.0.2.7.
  2. Would you please do a case study?

      Thank you very much for your answer,

Re: Parts lists have no effect.

Valued Contributor
Valued Contributor

No..I was talking about Customer default, or Preferences. If you have those problems with every part list.

Re: Parts lists have no effect.

Valued Contributor
Valued Contributor

So it looks like you have some problem with part name column setting. I found this thread:

https://community.plm.automation.siemens.com/t5/NX-Design-Forum/3-Dots-in-part-list/td-p/398907

 

So you can get row for each part. See the video. But I am not 100% sure, what is the best way to fix it corectly. You should check values of all the columns and try to get there corect attributes I guess. Looks like the translation into your language made a mess in it.

Re: Parts lists have no effect.

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @FZK,

 

The positioning problem with the parts list is that is has an associative origin.  If you follow @Radim_M's movie you'll see him right click the Parts List and choose Origin.  Note that the initial display of the Origin Tool dialog shows the Point Constructor icon is selected and that "Associative" is checked.  If you uncheck the "Associative" checkbox you'll be able to place the Parts List wherever you like.  Your Edit Levels settings seem to be ok.

 

The reason the columns aren't populated with values is that their columns are associated with attributes that don't exist in the component, for example, DB_PART_NO, DB_PART_NAME, which are attributes associated with NX Manager (Teamcenter managed NX).  You can reassign the attributes used to populate the columns with ones that are in the components ($PART_NAME, $COMPONENT_NAME).

 

The MATERIAL column is not populated because (a) Materials have not been assigned to the components and (b) the attribute likely incorrect.  Editing your part in my session uses NX Material for the attribute, therefore I have to reassign that attribute to the column to see the materials.

 

Hope that helps,

Regards, Ben

Re: Parts lists have no effect.

Valued Contributor
Valued Contributor

Hi @BenBroad

 

Thank you,Ben, for makeing it clear. I was a bit confused by the DB attributes. We start use NX and TC is in the preparatory phase so I will know then.

And I'd like to ask - The associativity of the origin - is it setable as default somewhere, or is it based on the last setting?