Cancel
Showing results for 
Search instead for 
Did you mean: 

Problem when adding component: "Version ... is already open."

Experimenter
Experimenter

Hello,

 

I am using NX 10. Recently I tried to add a component into an assembly when I got the error message:

 

"Version <Component_Name> is already open.

This may be because it was automatically loaded as a component of an assembly open in this session. Change your displayed part to access the loaded version of this part."

 

The component is already loaded in the assembly, but I need to add a second one. I tried it with other components with same effect.

 

Where is this coming from?

2 REPLIES

Re: Problem when adding component: "Version ... is already open."

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

How are you trying to add it?

Note in the "add component" dialog, the existing component SHOULD be listed in the list of files already open - I would select it here (rather than clicking on the option to open a new part)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Problem when adding component: "Version ... is already open."

Experimenter
Experimenter

I usually did it by using the "open" Button in the "Add component" window.

But yes, the problem did never appear when selecting from the list of files. I figured out that it does not appear either if the part is not in the list of files (what of course makes sense now). 

 

Thanks for helping.