Cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Java 8.121

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hello everyone!

 

Today I updated my Java to the most recent version 8.121 becasue I notived that documentation server stopped working. Documentation server resumed working but now I get "A Java exception was encountered" error when I try to launch Relations Browers - on any NX version I have installed? Any ideas? Is the Java version too recent?

6 REPLIES

Re: Problem with Java 8.121

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
my guess is that when you installed Java, it removed the previous version and installed the new version in a different folder, based on the version. The relations browser needs the UGII_JAVA_HOME variable (if my memory is right as I'm not in front of my pc) set to where Java is and its most likely pointed to the old location. Check what that variable is set to and adjust to suit the new Java install location.
Anthony Galante, Senior Support Engineer
PhoenxPLM
24 versions of NX installed: NX4 to NX12, plus TC11.2

Re: Problem with Java 8.121

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

No, I updated the java variable. If UGII_JAVA_HOME is wrong, NX returns different error message "Could not locate blah blah..."

Re: Problem with Java 8.121

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello @Scaffold

 

It looks like you are right... On my system running java 7 update 111, the relations browser starts, on my other system, with 121, it fails.

 

It would be best to report this issue to GTAC, so we can investigate, and file a PR for this. I would be able to do this myself, but Internal PR's have lower priority, so therefor it's best you report this.

 

Kind regards,

 

Dennis

Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: Problem with Java 8.121

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hi! Thanks for the information!

Re: Problem with Java 8.121

Siemens Phenom Siemens Phenom
Siemens Phenom

Some new info on this:

 

Issues with Java 8 update 121, should have been resolved in NX 10.0.3 MP14 and NX 11.0.1 MP1.

 

Kind regards,


Dennis

Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: Problem with Java 8.121

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

I think they are resolved for me, thanks!