cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with clone NX11.0.2, maybe

Pioneer
Pioneer

I cloned an imported stp file into a new job number using the rename name type. I now have all my assembly tree looking like I want it, but the name of each part, by looking at properties or on the quick pick menu are still the old name from before the clone, any ideas on this one?? Thanks

Capture.PNG

 

 

 

Brian
NX 11.0.2
Win 7 pro 64 bit
quadro k4000
3 REPLIES

Re: Problem with clone NX11.0.2, maybe

I think that you are displaying/seeing the component name.
Check the Name field in the General tab of the Component properties and see if it's a match. I'm not sure if you can address the component name in cloning, just the part name/number/description.

Re: Problem with clone NX11.0.2, maybe

Legend
Legend

Hi @brian1234,

try this journal :

Option Strict Off
Imports System
Imports NXOpen
Imports NXOpen.Assemblies

Module rename_all_components_to_use_descriptive_part_name

    Dim theSession As Session = Session.GetSession()

    Sub Main()

        Dim dp As Part = theSession.Parts.Display

        Dim c As Component = dp.ComponentAssembly.RootComponent

        ProcessAssemblyTree(c)

    End Sub

    Sub ProcessAssemblyTree(ByVal c As Component)

        Dim children As Component() = c.GetChildren()

        For Each child As Component In children
            child.SetName(child.DisplayName)
            ProcessAssemblyTree(child)
        Next

    End Sub

    Public Function GetUnloadOption(ByVal dummy As String) As Integer
        Return Session.LibraryUnloadOption.Immediately
    End Function

End Module
Thank you...

Using NX 11 / RuleDesigner PDM

Re: Problem with clone NX11.0.2, maybe

Pioneer
Pioneer

Perfect, thanks, that journal did it

Brian
NX 11.0.2
Win 7 pro 64 bit
quadro k4000