Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Question on roll back of NX version

Siemens Esteemed Contributor Siemens Esteemed Contributor
Siemens Esteemed Contributor

@Ken_A wrote:

Note there is an ENV variable

NX_COMPATIBLE_BASE_RELEASE_VERSION

 

I would ASSUME (but I do not know for sure) that any version that sets this the same will be open up a file 

e.g. NX1847, 1851, and (I am guessing) 1855 all have this set to "1847", so you (I assume) should be bale to open a file, saved in 1855, in 1847

 

Ken "caveat emptor" Akerboom 


I have 1855 installed and the value for this variable remains 1847.  The OOTB 1847 ugii_env_ug.dat file reads the following:

 

# The documentation Center keeps complete documentation for each MR, but
# a local server installs it all under the major version, take that into
# account here
#if ${UGII_UGDOC_BASE} = "https://docs.plm.automation.siemens.com"
UGII_DOC_VERSION=${NX_COMPATIBLE_BASE_RELEASE_VERSION}
#endif

#if ${UGII_UGDOC_BASE} = "http://docs.plm.automation.siemens.com"
UGII_DOC_VERSION=${NX_COMPATIBLE_BASE_RELEASE_VERSION}
#endif
UGII_DOC_VERSION=${NX_COMPATIBLE_BASE_RELEASE_VERSION}

So one has to assume that at the moment this variable is only used to point to the relevant documentation for the version used in session.


Regards, Ben

Ben Broad | PLM Enthusiast | Siemens GCSS

NX (v17 - 1872) | Teamcenter (9 - 12)
Value Based Licensing | Adaptive UI | BETA Registration

Re: Question on roll back of NX version

Siemens Genius Siemens Genius
Siemens Genius

Hello Ken,

 

This variable identifies the compatible base/functional release of the current NX session, in other words, the baseline build of the current NX session. So for a given NX series, this will be always the same as you correctly noted e.g. For NX1847 Series - NX1847 (Functional release), 1851 and 1855 (Monthly Updates) all will have this set to "1847".

 

Keeping this in mind all the part files will be both backward and forward compatible in the same series but only forward compatible when you jump from older to newer series. 

 

I hope this helps.

 

Regards

Shirish