Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: NX Support for El Capitan / MAC OSX v10.11

Creator
Creator

Hi

 

I had NX10 working on Yosemite. After upgrading yo El Captain I tried to follow this post to get NX10 working, but I am getting following error when I run second comman to Move the quarantined files.

 

"find:  exec: unknown primary or operator"

 

I am not an expert in using commanline tools. Can someone tell what is wrong?.

 

 

1 REPLY

Re: NX Support for El Capitan / MAC OSX v10.11

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

I think this is the command you're trying to run:

 

# Copy file from quarantined location … note the file is renamed
find /Library/SystemMigration/History/Migration-*/QuarantineRoot/usr -name libXm.3.1.dylib \ exec sudo cp -v {} /usr/local/lib/libXm.3.dylib \;

 

I don't have a copy of OS X 10.11 to check it on, but every other Unix/Unix-like operating system has find as a utility and if you look up its arguments you'll find one defined as "-exec":

 

-exec command ;
              Execute  command;  true  if 0 status is returned.  All following
              arguments to find are taken to be arguments to the command until
              an  argument  consisting of ‘;’ is encountered.  The string ‘{}’
              is replaced by the current file name being processed  everywhere
              it occurs in the arguments to the command, not just in arguments
              where it is alone, as in some versions of find.  Both  of  these
              constructions might need to be escaped (with a ‘\’) or quoted to
              protect them from expansion by the shell.  See the EXAMPLES sec-
              tion  for examples of the use of the ‘-exec’ option.  The speci-
              fied command is run once for each matched file.  The command  is
              executed  in  the  starting  directory.    There are unavoidable
              security problems surrounding  use  of  the  -exec  option;  you
              should use the -execdir option instead.

Example:
              find . -type f -exec file '{}' \;

Runs `file' on every file in or below the current directory.  
Notice that the braces are enclosed in single quote marks to protect them from
interpretation as shell script punctuation. The semicolon is similarly
protected by the use of a backslash, though single quotes could have been used
in that case also.

 

That leads me to believe that the command has a typo in it where "exec" should really be "-exec".

 

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC