Cancel
Showing results for 
Search instead for 
Did you mean: 

Reference Set Changed - facing this issue after moving from NX85 to NX10

Experimenter
Experimenter

We recently moved from NX85 to NX10.

When loading the replica, We are continously facing this issue after the upgrade. We found named references are empty for some of the components, and Site A assembly (replica) is not fully loaded in Site B.

 

I tried data sync, which completed with no issues, but still full asembly is not loaded in Site B. Designer says, named reference is empty for some of the parts and everytime they import sub assembly wise and part wise to site B and proceed with their work. Only after the manual import the issue gets fixed.

Seems to me that there is no issues with data sync utility. But suspecting, if it something to do with NX 10 upgrade??? 

Below is the error (Siemens GTAC says this error is data specific issue in remote Site that is Site A). Anyone know how to fix this? 

 

ERROR:

The following substituted component in Teamcenter094K05601/A.001 replaced with 094K05600/A.001

The following substituted component in Teamcenter094K05600/A.001 replaced with 094K05601/A.001

The following substituted component in Teamcenter018K01451-1/A replaced with 018K01450-1/A

The following substituted component in Teamcenter018K01450-1/A replaced with 018K01451-1/A

The following substituted component in Teamcenter018K01451-3/A replaced with 018K01450-3/A

The following substituted component in Teamcenter018K01450-3/A replaced with 018K01451-3/A

The following substituted component in Teamcenter018K01451-2/A replaced with 018K01450-2/A

The following substituted component in Teamcenter018K01450-2/A replaced with 018K01451-2/A

The following substituted component in Teamcenter049K40811-1/A replaced with 049K40810-1/A

The following substituted component in Teamcenter049K40810-1/A replaced with 049K40811-1/A

The following substituted component in Teamcenter049K40811-2/A replaced with 049K40810-2/A

The following substituted component in Teamcenter049K40810-2/A replaced with 049K40811-2/A

The following substituted component in Teamcenter632W22352/B.004 replaced with 632W21252/B.004

The following substituted component in Teamcenter632W21252/B.004 replaced with 632W22352/B.004

date - Fri Mar 10 17:43:06 2017

Important information during successful load
XRX-00187383/A.001;1-CART SWITCH LAYOUT The load was successful. However, there are some points you should note regarding
potential problems encountered during this process. Please read the following list carefully:

Components not loaded
One or more components of the following parts have not been loaded from Teamcenter:
XRX-00185330/A.001;1-CART ELEVATOR LAYOUT-LIN ACT
XRX-00194051/A.001;1-CART ELEVATOR LAYOUT-LIN ACT

This is probably because you do not have the right privileges to access the part files or the parts are remote.

Part is remote
/
Unable to get display name for this part
You have specified a part which is a remote one in Teamcenter.

Reference Set changed
The following improper reference sets were set to that found in the Teamcenter product structure:
[MODEL] on part: [003K22132/A.001]
[MODEL] on part: [012K07531/B.001]
[MODEL] on part: [016E23030/A]
[MODEL] on part: [029E59940/A]
[MODEL] on part: [050K77370-1/B.002]
[MODEL] on part: [0LD-DELETE THIS 815K35380/A.001]
[MODEL] on part: [120E42490/A.001]
[MODEL] on part: [674K11860/A.001]
[MODEL] on part: [674K11870/A.001]
[MODEL] on part: [674K11890-1/A.001]
[MODEL] on part: [674K11890/A.001]
[MODEL] on part: [813W23526/A.001]
[MODEL] on part: [813W23613/A.001]
[MODEL] on part: [815K35540/A.001]
[MODEL] on part: [822E33410/B.001]
[MODEL] on part: [825E20320/A.001]
[MODEL] on part: [869E27021/A]
[MODEL] on part: [869E27481/A.001]
[MODEL] on part: [869E56660/A.001]
[MODEL] on part: [892E63022/W]
[MODEL] on part: [AAA CART ELEVATOR ASSY/A.001]
[MODEL] on part: [BRKT-LOWERING LIMIT SWITCH/A.001]
[MODEL] on part: [CARTSADDLE/A.001]
[MODEL] on part: [XRX-00179555/A.001]
[MODEL] on part: [XRX-00182390-1/A.001]
[MODEL] on part: [XRX-00182390/A.001]
[MODEL] on part: [XRX-00182459-1/A.001]
[MODEL] on part: [XRX-00182478/A.001]
[MODEL] on part: [XRX-00185529/A.001]
[MODEL] on part: [XRX-00185642/A.001]
[MODEL] on part: [XRX-00185644-3/A.001]
[MODEL] on part: [XRX-00185644/A.001]
[MODEL] on part: [XRX-00185657/A.001]
[MODEL] on part: [XRX-00185709/A.001]
[MODEL] on part: [XRX-00185712/A.001]
[MODEL] on part: [XRX-00185714/A.001]
[MODEL] on part: [XRX-00185715/A.001]
[MODEL] on part: [XRX-00185716/A.001]
[MODEL] on part: [XRX-00185717/A.001]
[MODEL] on part: [XRX-00187381/A.001]
[MODEL] on part: [XRX-00187382-1/A.001]
[MODEL] on part: [XRX-00187382/A.001]
[MODEL] on part: [XRX-00187405-1/A.001]
[MODEL] on part: [XRX-00187405/A.001]
[MODEL] on part: [XRX-00187937/A.001]
[MODEL] on part: [XRX-00187975/A.001]
[MODEL] on part: [XRX-00187997-1/A.001]
[MODEL] on part: [XRX-00187997/A.001]
[MODEL] on part: [XRX-00188033-1/A.001]
[MODEL] on part: [XRX-00188033/A.001]
[MODEL] on part: [XRX-00192282/A.001]
[MODEL] on part: [XRX-00192303-1/A.001]
[MODEL] on part: [XRX-00192303/A.001]
[MODEL] on part: [XRX-00192304/A.001]
[MODEL] on part: [XRX-00192409-1/A.001]
[MODEL] on part: [XRX-00192412/A.001]
[MODEL] on part: [XRX-00192492-1/A.001]
[MODEL] on part: [XRX-00192492-2/A.001]
[MODEL] on part: [XRX-00192492/A.001]
[MODEL] on part: [XRX-00192519/A.001]
[MODEL] on part: [XRX-00192525/A.001]
[MODEL] on part: [XRX-00192527-1/A]
[MODEL] on part: [XRX-00192527/A.001]
[MODEL] on part: [XRX-00192642-1/A.001]
[MODEL] on part: [XRX-00192642-2/A.001]
[MODEL] on part: [XRX-00192642-3/A.001]
[MODEL] on part: [XRX-00192642/A.001]
[MODEL] on part: [XRX-00192643/A.001]
[MODEL] on part: [XRX-00192644/A.001]
[MODEL] on part: [XRX-00192646/A.001]
[MODEL] on part: [XRX-00192758/A.001]
[MODEL] on part: [XRX-00192759/A.001]
[MODEL] on part: [XRX-00192888/A.001]
[MODEL] on part: [XRX-00192914/A.001]
[MODEL] on part: [XRX-00192955-1/A.001]
[MODEL] on part: [XRX-00192958/A.001]
[MODEL] on part: [XRX-00193076/A.001]
[MODEL] on part: [XRX-00193235/A.001]
[MODEL] on part: [XRX-00193236/A.001]
[MODEL] on part: [XRX-00193237/A.001]
[MODEL] on part: [XRX-00193238/A.001]
[MODEL] on part: [XRX-00194053/A.001]
[MODEL] on part: [XRX-00194054/A.001]
[MODEL] on part: [XRX-00194056/A.001]
[MODEL] on part: [XRX-00194057/A.001]
[MODEL] on part: [XRX-00194058/A.001]
[MODEL] on part: [XRX-00194059/A.001]
[MODEL] on part: [XRX-00194065/A.001]
[MODEL] on part: [XRX-00194087/A.001]
[MODEL] on part: [XRX-00194089-1/A.001]
[MODEL] on part: [XRX-00194089/A.001]
[MODEL] on part: [XRX-00194090/A.001]
[MODEL] on part: [XRX-00194305/A.001]
[MODEL] on part: [XRX-00194306/A.001]
[MODEL] on part: [XRX-00194308/A.001]
[MODEL] on part: [oldXRX-00192970-1/A.001]

This may be because the reference sets do not exist.It is possible that you incorrectly entered the reference set names
when editing in Teamcenter.
NX would try to reset them with the Reference Sets listed in the Assembly Load Options

Unexpected structure of in-sync assembly
The following part is marked as in-sync with NX but has unexpected structure in Teamcenter:

003K10431/A;1-HINGE ASSY-FLAPPER
003K18112/A;1-HINGE ASSY-FRMUPR
007K20000/A;1-GEAR ASSY-IDLER DONOR 51T
013K02643/B;1-PLATE TOP ASSY-BEARING-IB-B1
018K01451/A;1-GREEN FLAG INDICATOR BRKT ASSY
030K70431/A;1-BRACKET ASSY-1/4 TURN_RECEPT
030K70441/A;1-BRACKET ASSY-1/4 TURN
049K30990/A.002;1-BRACKET TOP ASSY-Y-LOCATOR_OB_5TH HSG
049K40720/A;1-WINCH MOUNT BRACKET ASSY
049K40811/A;1-NEW PULLEY BRKT OB ASSY
050K77361/A.001;1-HOPPER ASSEMBLY
094K05490_SHORT RUN/A.001;1-AUGER-PICK UP ASSY-5TH DEV HSG
121K32953/C.001;1-MAGNET ASSY P1 (-2.5 CORE)
130K75940/A;1-SENSOR ASSY-TONER CONCENTRATION
815K35540/A.001;1-PLATE ASSY-ACTUATOR SWITCH ADJUST
XRX-00185716/A.001;1-BRACKET DRAWER ROLLER MTG-2
XRX-00192412/A.001;1-SWITCH ASSY-TRAY POSITIONING
xxxWxxxxx_5th HSG/A.001;1-ZZZ_HARDWARE-TOP ASSY_5TH DEV HSG


Although this assembly is marked as in-sync with Teamcenter, it has one or more components
in its Teamcenter structure that are not in the NX assembly file structure. If you want these
components in your NX structure you don't need to do anything else, since NX has loaded
the structure that way. If you do not want these components in your NX structure, load
the assembly with structure update on load set to None and then save it to Teamcenter.

 

 

 

2 REPLIES

Re: Reference Set Changed - facing this issue after moving from NX85 to NX10

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @Xerox_Corp,

 

This question would be better asked in the "Teamcenter Administrators" forum.

 

That said, it appears that there might be a sync issue between Site A and Site B if you're getting different results between each site.  Do you get the same feedback if you load the data from Site A in NX10? 

 

Upgrading from NX8.5 to NX10 would not cause the problem, though you should ensure that your customer defaults are the same between versions if you want consistency. Upgrading NX does not remove content from the named references of datasets.  I believe the messages below only get raised if you have the customer default "Structure Update on Load" set to something other than "None".

 

Based on the messages returned by NX:

  • "The following substituted component in Teamcenter..."
    The BVR has different structure to what was last saved in the assemblies part files usually due to manual edits in Structure Manager.
  • "Components not loaded"
    The items are missing or the datasets' named references are empty.
  • "The following improper reference sets were set to that found in the Teamcenter product structure"
    Reference Sets have been manually defined in the BVR using Structure Manager that do not match what are available in the part files.

Regards, Ben

Re: Reference Set Changed - facing this issue after moving from NX85 to NX10

Experimenter
Experimenter

Thanks for your feedback Ben.

 

We are not getting any issue while loading in Site A.

 

Customer default "Structure Update on Load" is set to ''Add components that have a position" in SIte A.

 

I am changing the customer default "Structure Update on Load" from Complete to ''Add components that have a position" in SIte B.

 

I have also got some response from GTAC, to data push from Site B to Site A for all componenets that has missing named references.

 

Let me give it a try with your suggestions.