Cancel
Showing results for 
Search instead for 
Did you mean: 

Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Creator
Creator

Hello everybody,

 

on our parts we often have to create dimensions in a drawing which cannot be referenced to the solid geometry directly, but to points for example which are located on the solid geometry. But in the end we do not want to see these Points in the drawing view. Please don't question this method, it is how it is and it makes sense for us. Smiley Wink

 

The Problem I have now, is that in the past with NX10 and NX11 I was able to hide the points the dimension is referencing to by hiding the layer the points are located on with "Layer visible in view" for each view and the dimension was still associative to the points and working. Now with NX12 the dimension becomes a retained dimension, which looses it's reference. I have drawing which were created before NX12 and they are still working fine, but in a new drawing which is created with NX12 from the same template, the dimensions loose their reference and associativity to the points.

 

I was searching for a setting in NX which would influence that behaviour, but I cannot find anything.

 

Does anybody know if this has changed from NX10/11 to NX12 or if there is any setting where I can get back to the old behaviour?

 

Thanks,

Ralph

11 REPLIES

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @Rago,

 

I've reproduced the behavior you reported.  Starting NX 12 points are now defined as 'Drafting Point (Extracted Point)' whereas in NX 11 they were 'Point of Point'.  You might want to consider calling GTAC and reporting this 'regression'.

 

I was unable to locate any customer defaults or Drafting preference to revert to the previous behavior.  A couple of possible workarounds:

  • Create a Sketch in the view and create sketch points based on the new Extracted Points.  Once the Sketch Points have been dimensions uncheck (hide) the Sketch via the Part Navigator and use Visible in View to hide the model points in the view.
  • Turn on 'Enable Exact (Pre-NX 8.5) Views' in the Customer Defaults which would allow you to disable Extracted Edges having placed an Exact Pre-NX 8.5 view on your drawing.

Regards, Ben

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Phenom
Phenom
@BenBroad,

I've seen the same sort of behavior for curves in Modeling using NX11 - they're reported (in Drafting) as some sort of Extracted Curve.
-Tim

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

One more work-around to add to @BenBroad's suggestions:

After placing the dimension, expand the view and hide (blank) the points.

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi Rago,

 

Im sorry that this has become an issue for you. I sugest the same as Ben. In the meantime maybe View Dependant edit would be an alternative for you. Hava a look at the attched movie showing a dimension referencing points where turning the layer holding the points results in retained dimension as to where View Dependant edit will keep the dimension up to date.

 

Best Regards

Fred

 

(view in My Videos)

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Builder
Builder

Dear @Rago

 

You can simply use view dependent edit and select all points to hide them.

Sina Shojaee

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Creator
Creator

Hello everybody,

 

thank you all for your replies, unfortunately that's not what I hoped to read. Smiley Sad

 

To us this is a massive regression to NX11/10, I cannot understand why this changed and I will raise a GTAC Ticket.

 

The workaround via "View Dependent Edit" is doable, but makes our work much more complicated. We usually have different point sets with many points on different layers and it is much easier to turn the layers on and off then selecting them via "View Dependent Edit".

 

Thanks,

Ralph

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Creator
Creator

By the way...

 

The funny thing is, if I take a drawing which was created under NX10 or 11 and open it with NX12, the old behavior still works and I can hide the points via "Layer visible in view" and the dimensions are working fine. Even if I create new dimensions it is working.

 

I still hope that there is an option to get back to the old behavior...

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Siemens Genius Siemens Genius
Siemens Genius

Hi @Rago,

 

The extacted points in view will get generated only when the view(created in earlier release of NX) is versioned up. If you create a new view, then it will have the extracted points automatically generated. Thats why you will see your workflow still working for older views.

 

You can create PMI Dimensions associated to the points in modeling application and then you can inherit the PMI onto the views. So, even if you then remove the display of points in drawing views using layers, the dimensions are still going to be alive.

 

Thanks,

Amit

Re: Retained Dimension in Drafting after hide Reference by "Layer visible in view"

Builder
Builder

Dear @Rago

 

If you want to use view dependent edit command, then you can also use layer filter to select all your points both when you use Erase Objects and Delete Selected Erasures to hide or show the objects.

Sina Shojaee