Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Round holes showing up square

Siemens Phenom Siemens Phenom
Siemens Phenom

That's why it was made optional.

 

As for why Siemens made the new behavior the default, as I have stated many times when I was still with the company, we did this by design.  If we had made a change, which in this case offered better performance, but had not made it the new default, no one would ever notice it.  And if someone complained about performance, what are the chances that they would look around to see if some new option had been added that might help (be honest when you answer this, OK)?

 

Now, as you've so eloquently demonstrated, some of you feel that you would prefer the older, albeit slightly less efficient, scheme for controlling how and when the display of curved edges are updated and so you've taken the time and effort to discover how to switch it back.  But now you DO know that there is a new option that perhaps in the future, when display performance may became a critical issue, you will recall this option and perhaps give it another try.  However, if Siemens had NOT made it the new default you could very well have remained unaware of this option that could provide for better overall display performance if and when that might become an issue.

John R. Baker, P.E. (ret)
EX-Product 'Evangelist'
Irvine, CA

Re: Round holes showing up square

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

I'm curious how much of a performance boost Siemens expected/experienced with this new default? I don't notice any difference in performance after increasing the display quality.

Full disclosure, the parts I work on have lots of freeform surfaces, but the assemblies are pretty small. I expect others, that work with large assemblies will experience bigger performance gains.

 

I've never heard anyone sit down with NX 9 and comment "wow, the display renders 5% faster!", but I have heard lots of complaints about the jagged, mismatched edges.

 

I'm just reporting user perception from my own experience.

 

I work in the "consumer goods" industry. Our product reviews are not always favorable. We have the choice to explain those reviews away or dig into them to see what we can use to make a better product. Siemens has the same choice.

Re: Round holes showing up square

Legend
Legend

For me the "jaggies" were a huge problem at 1st.

I've since created a few template parts with the settings the way I want them and I always use them to start a project.

When I'm using imported data, or even NX parts from other customers I just wave link and extract the body or bodies into my part. now I don't have to deal with the crappy default tesselation settings.

 

I cannot even count how many times I've heard from people "why is NX graphics so **bleep**ty.  NX7.5 was so much better"

 

 

Rob Newcomb, CAD/CNC/Simulation manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.1 / Autoform r7 /WorkNC 2018 r2
Testing:nothing.
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro

Re: Round holes showing up square

Gears Phenom Gears Phenom
Gears Phenom

Are the visualization preformance settings, part, or session specific?  or does it stick 'forever' when a user sets them?

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Round holes showing up square

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

The tessellation settings that are the subject of this thread are part specific.

Re: Round holes showing up square

Phenom
Phenom

BenBroad wrote:

@cubalibre00, I suspect in your example above that you're display issue is due to the Facet Scale being set to "Part".  Per the docs this setting "Adjusts the Resolution Tolerances settings based on the bounding box for the part. The larger the part, the coarser the tolerance. "  Therefore, if you have a large part and zoom into a small area expect the facets to be large and not adjust.  Note also that "For pre-NX 9 parts, NX converts Facet Scale type from View to Part ."

I suspect that setting the Facet Scale to "View" will improve your facet display when you zoom into these smaller areas.  Alternatively, set the Facet Scale to Fixed and adjust the Resolution Tolerance.  You mention that Update Display does not improve the display, that may be because your Facet Scale is set to "Fixed".

The documentation does a pretty good job explaining the settings here:

https://docs.plm.automation.siemens.com/tdoc/nx/10/nx_help/#uidSmiley Tonguereferences_prf_vis_facet_op

 

Further reading:

https://solutions.industrysoftware.automation.siemens.com/docs/newsletter/nx-understanding-tessellat...

 

Regards, Ben


Hi Ben,

I've read and read, changed every setting, but I'm not able to resolve the 'Jaggies'. Can I upload an assembly example so you can test it and describe, if it's possible, improve the visibility ?

Thank you...

Using NX 11 / RuleDesigner PDM

Re: Round holes showing up square

Siemens Phenom Siemens Phenom
Siemens Phenom
Yes, no problem, though it might be easier for to coordinate with your local GTAC office as they're in the same time zone. They should be able to help you and they can contact me if needed.
Regards, Ben

Re: Round holes showing up square

Siemens Phenom Siemens Phenom
Siemens Phenom
Do you have "Save Shaded Display Facets" checked in your Visualization Performance Preferences?

Menu > Preferences > Visualization Performance > General Graphics (tab) > Part Settings
Note: Part Settings is a collapsed field at the bottom of the dialog.

Ben

Re: Round holes showing up square

Phenom
Phenom

BenBroad wrote:
Do you have "Save Shaded Display Facets" checked in your Visualization Performance Preferences?

Menu > Preferences > Visualization Performance > General Graphics (tab) > Part Settings
Note: Part Settings is a collapsed field at the bottom of the dialog.

Ben

Hi Ben,

the option is set.

Thank you...

Using NX 11 / RuleDesigner PDM

Re: Round holes showing up square

Siemens Phenom Siemens Phenom
Siemens Phenom
In that case uncheck "Save Shaded Display Facets" and then make a change to the Facet Scale (e.g, from Part to View) to cause the facets to change, and then zoom in and try Update Display.

Ben