Cancel
Showing results for 
Search instead for 
Did you mean: 

Sketch lines not visible in drafting view.

Experimenter
Experimenter

Hello together. 
I recently switched from NX 10 to NX 11 and i am designing panels to be laser cut. For now i would sketch the outline in a part file, add the part in the drafting module, the sketch would appear and I could export it to pdf. 
Right now, none of the sketched lines are apprearing in the drafting mode only a black cross with a circle at the bottom left corner.,solid bodies are visible though. I have been already trying out all kind of ideas for 3 hours but couldnt find a solution.
Do you have any idea where that issue comes from and how to solve it?
Thanks a lot already!

Alex

8 REPLIES

Re: Sketch lines not visible in drafting view.

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @Alex_Gors,

 

Do you create your drawings as a separate part file from the sketch (a.k.a master model)?

 

The usual causes for geometry not showing up in drafting:

 

  • Views are "View of part", not the drawing.  Thus if new geometry is added to drawing it does not show in the drawing views (master model)
  • Incorrect Reference Set specified for model.  Right click the model node in the ANT and check the Reference Set (master model)
  • Geometry added to layers that are "invisible in view" in drafting.  Check which layer the geometry was added to in Modeling.  In Drafting select "Menu > Format > Layer Visible in View", select the view and see if the layer is invisible.
  • Geometry added is same color as drawing background (or foreground).  Usually occurs when Monochrome is used in Visualization Preferences. 
  • Geometry is created as view dependent in modeling, or objects have been view dependently erased in the drafting view being updated.
  • Geometry was created in Hidden mode.  With the drawing displayed select "Ctrl + Shift + B" (Invert Shown and Hidden) to see if it appears.  Repeat this step to revert back to Shown mode.

 

Regards, Ben

Re: Sketch lines not visible in drafting view.

Experimenter
Experimenter

Hi BenBroad, 
Thank you for your help. I am creating the drawing as a separate part file from the sketch. 
What do you mean by "view of parts"? I dont have created any new views, so i guess there shouldnt be any issue there.
Can i select a reference set for the model as it is not in an assembly?
I checked the layers and everything seems to be in Layer 1 or 61 for the datums and all layers should be visible in the sketch.

I tried monochrome on and off in the drafting mode / visualization preferences, but no change

I dont really know how to check that point:
"Geometry is created as view dependent in modeling, or objects have been view dependently erased in the drafting view being updated"

I tried the hidden option as well. 
I also remember that when i usually added the component to the draft, i had the datum system etc all apprearing which i had to hide. Now only solids are showing up.
I attached some screenshots of the file settings as well what i get in the drafting view

layer visible drafting.PNGin draftpart & layer settings.PNGin modelview_drafting.PNGwhat i get after adding the component

Re: Sketch lines not visible in drafting view.

Experimenter
Experimenter

I guess i found the problem with the lines. As you suggested, in drafting, the reference set was set to model and not entire part. 
The sketches are apprearing if I set the reference set to entire part before adding any views. The thing i dont understand though is, that if i change the reference set back to model, the sketch stays visible and only the datums dissapear.

And one more question i couldnt find any solution for: How can I change the color of individual lines or whole sketches? I tried to change it through the right click on drawing frame --> edit -->visible lines -->color and i disabled the monochrome toggle in visual preferences.
Thank you and kind regards,
Alex

Re: Sketch lines not visible in drafting view.

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

@Alex_Gors

how did you create your drawing? Master model way or not?

 

If you are using the master model (reference existing) method than you are able to change de reference set of the part.

 


Ruud van den Brand
Pre-sales NX CAD
cards PLM Solutions

Re: Sketch lines not visible in drafting view.

Experimenter
Experimenter

@ruud_vandenbrand 
Yes, i used the master model way.

Re: Sketch lines not visible in drafting view.

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

@Alex_Gors If open the drawing can you go to the assembly navigator, Right click on the part (not the drawing) and check there the reference set that is active.


Ruud van den Brand
Pre-sales NX CAD
cards PLM Solutions

Re: Sketch lines not visible in drafting view.

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @Alex_Gors,

 

Hopefully this video helps (there is audio):

 

(view in My Videos)

 

A couple of notes:

  • 1:50 - I incorrectly stated layer 1 is turned off.  I meant to say layer 61.
  • 2:30 - I incorrectly stated that the view was created "after I turned on layer 61".  It was created before I turned on layer 61, which is why the layer remains invisible in the drafting view.
  • Note that the view does not show out-of-date after replacing the reference set.  Enhancement Request ER 7769077 has already been submitted asking that the views show the out-of-data status following this change.

Let us know if you have any outstanding questions.

 

Regards, Ben

Re: Sketch lines not visible in drafting view.

Experimenter
Experimenter

@BenBroad

Thank you very much for that comprehensive explication!
Kind regards, 
Alex