Cancel
Showing results for 
Search instead for 
Did you mean: 

Strange Lines with Face Edge Display

Experimenter
Experimenter

Hi,

 

I am running NX12.01.

 

A new problem has popped up that was not present yesterday. When I open parts and assemblies there are spurious thin black lines displayed. The black lines display only when 'face edges' is selected in the visualization group of the 'View' tab, when in assemblies or modelling mode.

 

If I use show and hide, hide all, then show only bodies, the lines are there.

If I open a sub assembly, or a single part the lines are there.

If I switch off face edges, the lines disappear, so it appears to be something to do with the calculation and rendering of 'face edges'.

This only seems to be causing an issue with parts that have been translated from a step file into NX, however, this issue was not present before and a colleague can open the same file and doesn't see the lines.

 

Has anyone had a similar issue? Could this be a graphics card problem?

 

I had fiddled about with various settings in 'preferences', but nothing seems to clear away these odd black lines.

 

 

 

many thanks,

Chris

7 REPLIES

Re: Strange Lines with Face Edge Display

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @CPGL,

 

Can you upload a screenshot?  I'm assuming these 'spurious thin black lines' (face edges) are appearing where you would not expect to see them.

 

Thanks, Ben

Re: Strange Lines with Face Edge Display

Experimenter
Experimenter

Hi Ben,

 

See screengrab, ammended for IP reasons.

 

Hopefully this will help explain - I see the lines in fairly random locations (I am sure they are anything but!) and they seem to disappear if I zoom in close enough.

 

I am not seeing them with all parts of the assembly - they seem to crop up only in an assembly.

 

If I turn off face edges, they disappear.

 

I would not expect to see these at all - they disappear when I hide all and then reappear when I 'show' bodies.

 

cheers,

Chris

Re: Strange Lines with Face Edge Display

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Could be a graphics card issue.

What graphics card (and driver version) are you using?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Strange Lines with Face Edge Display

Experimenter
Experimenter

Hi Ken,

 

Here is some output from DirectX Outpout tool:

 

---------------
Display Devices
---------------
Card name: AMD Radeon HD 6570
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x6759)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_6759&SUBSYS_3130103C&REV_00
Display Memory: 4095 MB
Dedicated Memory: 1004 MB
Shared Memory: 3091 MB
Current Mode: 2560 x 1440 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: HP Z27i
Monitor Id: HWP3095
Native Mode: 2560 x 1440(p) (59.951Hz)
Output Type: Displayport External
Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver File Version: 8.17.0010.1072 (English)
Driver Version: 8.840.0.0
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 3/10/2011 05:53:30, 788480 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71EE2-2419-11CF-BC77-3A11BEC2C535}
Vendor ID: 0x1002
Device ID: 0x6759
SubSys ID: 0x3130103C
Revision ID: 0x0000
Driver Strong Name: oem14.inf:ATI.Mfg.NTamd64.6.1:ati2mtag_NI:8.840.0.0Smiley Tongueci\ven_1002&dev_6759&subsys_3130103c
Rank Of Driver: 00E60001
Video Accel: ModeMPEG2_A ModeMPEG2_C

 

 

Re: Strange Lines with Face Edge Display

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Definitely a graphics device/driver issue.

 

Regarding your 'AMD Radeon HD 6570' - per the hardware certifications:

Radeon refers to consumer/gamer graphics. Radeon Pro is the only brand certifed.

 

I've seen similar display issues before and typically with 'gaming' level devices.  Sometimes the higher end devices produce display anomalies like this, but it's usually due to a non-certified graphics device driver.

 

You may find that installing a newer graphics driver resolves this issue, or perhaps executing the 'Evaluate Graphics Performance' command (Preferences > Visualization Performance > General Graphics tab).  Windows 10 updates recently messed up a bunch of graphics driver registry settings, so you might find that uninstalling/reinstalling your current driver resolves the issue.

 

Regards, Ben

Re: Strange Lines with Face Edge Display

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Also note that NX uses OpenGL graphics, not DirectX 9hence some of the issues with "gaming" level cards)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Strange Lines with Face Edge Display

Experimenter
Experimenter

Thanks all for your help, the problem was resolved by a driver update on the graphics card.

 

Graphics driver did seem to be the issue - obviously some recent change in the NX or Windows software had made some minor incompatibility issue.