cancel
Showing results for 
Search instead for 
Did you mean: 

Surface through curves - edge doesn`t match

Valued Contributor
Valued Contributor
Hello everybody, we`have created lines and splines with imported points for creating a surface. The inner and outer diameter lines are splines. Creating the surface is no problem, but when we zoom into the file, you can see that the edge of the spline and the edge of the surface doesn`t match together. Does anybody know why and can give as support! Attached you can find the part. Best regards! Frank
6 REPLIES

Re: Surface through curves - edge doesn`t match

Have you tried View -> Operation -> Regenerate work to ensure that what you see isn't just graphics related?
Can you measure any differences between splines and surface edges? Try "Shaded with edges" View Style to possibly easier see problems...
I think that what you see is just graphics related and not a difference between edges and splines.

Re: Surface through curves - edge doesn`t match

Valued Contributor
Valued Contributor
Hi Lars, i have tried your suggestion with "View-->Operation --> Regenerate Work", but it doesn´t work. I measured the distance in several ways and the result was zero. So i think you are right, that the problem is the rendering. Is there any other suggestion how i can fit the surface and spline, so that the graphic is correct? Thanks for your support! Frank

Re: Surface through curves - edge doesn`t match

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

How big is your part?

 

This can also be a tolerance problem.

Check you tolerance of the through curves feature.

Maybe try to set this lower.

 

Other its also if you you use cross curves to use the "through curve mesh" commnand.

This command is all most the same as through curve but you can set now also the cross curves to get a good closed surface.


Ruud van den Brand
Pre-sales NX CAD
cards PLM Solutions

Re: Surface through curves - edge doesn`t match

Honored Contributor
Honored Contributor

This looks like a result of your tesselation settings. I'd suggest changing the facet scale to "view" and turning on the "align facets along edges" option. Have a look at this document for more info.

Re: Surface through curves - edge doesn`t match

Valued Contributor
Valued Contributor
Thanks for your help everybody! I tried your solutions an phenom got the right answer for our problem by changing the facet scale. Best regards! Frank

Re: Surface through curves - edge doesn`t match

Siemens Phenom Siemens Phenom
Siemens Phenom

Just a quick note regarding "align facets along edges", per the documentation: "When the Align Facets along Edges check box is selected, the rendering time required to generate the facet edges may increase".

 

This is noticeable in larger, complicated parts.

 

Regards, Ben