Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Trim a sketch line at a datum plane

Pioneer
Pioneer

Hi, All!  I'm new to both Siemens NX and to the community.  Please bear with me as I refer to all features, procedures and objects by the wrong names, ask interminal dumb questions and generally cause eye-rolling to the point of headaches.  I've got a demo copy of NX11 (until the bean counters get off their ***** and write a check)... and my boss has entrusted my green self with the task of creating 4 fairly complex models and 2 REALLY complex models in a month.  Lucky me.  What I've learned so far is, NX is really hard.

 

I have a sketch in which I need to trim a line at a datum plane.  I can't find a way to project the plane to the sketch, and the trim command doesn't recognize the plane.  I can't dimension the endpoint to the plane, either.  Is is possible to project a plane in a sketch?  Thanx.

10 REPLIES 10

Re: Trim a sketch line at a datum plane

Gears Phenom Gears Phenom
Gears Phenom

@lonesome-joe,

 

 

A few ways to do this:

 

1. Use Quick Extend.
2. Use a Geometric Constraint - Point On Curve, endpoint of the line on the plane.
3. Use a Perpendicular Dimension to the Datum Plane.

4. Double click the line, at the bottom of the dialog (make sure it's fully expanded) you should see the curve limits - start and end - change the appropriate limit to Until Selected and then select the Datum Plane.

 

All of the above work in NX11.0.1.

 

 

Tim
NX 11.0.2.7 MP11 Rev. A
GM TcE v11.2.3.1
GM GPDL v11-A.3.5.1

Re: Trim a sketch line at a datum plane

Pioneer
Pioneer
Tried all of 'em, the problem is, when editing the sketch, NX doesn't recognize the datum plane, i.e., I can't select it.

Re: Trim a sketch line at a datum plane

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

The datum plane will need to come before the sketch in the feature tree. A feature that comes after the sketch doesn't exist when you are editing the sketch and therefore cannot affect the sketch.

Re: Trim a sketch line at a datum plane

Gears Phenom Gears Phenom
Gears Phenom

@lonesome-joe,

 

In addition to the above, make sure your Selection Scope is not set to Within Active Sketch Only.  You should be able to select almost any geometry outside of a Sketch just like in the attached movie.  If you can't then you have something set such that it's preventing it from behaving the way you wish.

 

 

 

 

Tim
NX 11.0.2.7 MP11 Rev. A
GM TcE v11.2.3.1
GM GPDL v11-A.3.5.1

Re: Trim a sketch line at a datum plane

Phenom
Phenom

Check the attachment. Edit the Sketch(1) (=Boundary curve) and observe Sketch(2) is trimming up to  its projection.

Is this what you are looking for?

image.png

Michael Fernando


Die Designer
NX 11.0.2.7 + PDW

Re: Trim a sketch line at a datum plane

Pioneer
Pioneer
All:
cowski1 wins the prize, indeed, I had made the datum plane after I made the sketch. I would's run into this same problem in Inventor of SolidWorks, too, I just lost focus. Thanx for your help!

Re: Trim a sketch line at a datum plane

Gears Phenom Gears Phenom
Gears Phenom

@lonesome-joe,

 

If you set your Modeling Preferences under the Edit tab, Double-click Action (Sketches) to Edit With Rollback you won't see features that come after the Sketch when you're in Edit mode.  That might present to you a bit more of a clue when you run into timestamp related conundrums like this one.

 

I've always preferred the Edit with Rollback option when editing things because it can remove potential problem makers.

Tim
NX 11.0.2.7 MP11 Rev. A
GM TcE v11.2.3.1
GM GPDL v11-A.3.5.1

Re: Trim a sketch line at a datum plane

Pioneer
Pioneer
I don't have an "Edit" tab... Smiley Sad

Re: Trim a sketch line at a datum plane

Honored Contributor
Honored Contributor

File, Preferences, Modeling, then the Edit tab.

 

I'd also change it here:

File, Utilities, Customer Defaults, Modeling, General, Edit

-Dave
NX 11 | Teamcenter 11 | Windows 10