Cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble adding knowledge enabled part

Experimenter
Experimenter

Hi, I'm trying to add a krx file in an NX/Teamcenter environment. I have followed the instructions in the manual

- Create krx file, from part with expressions
- Created a spreadsheet and added it within the krx file
- Set the driving parameters

Still when I add the part into an assembly via reuse library, I dont to change the parameters. On the file in teamcenter the spreadsheet does not show either even with refresh. If I try to add it directly to the part with drag and drop, I get some error message which goes away so fast I cant even print screen it.

Any suggestions what is wrong?

PS, spreadsheet is added is an attachment

3 REPLIES

Re: Trouble adding knowledge enabled part

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

You could try to see if the error message is in the syslog file (Help -> Log file; go to the bottom & scroll up)

There could be some more info pointing you at the real issue.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Trouble adding knowledge enabled part

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
did you tried this part in native NX (without teamcenter)
You have in de default library a example part.
go to reusable objects->metric->snap->snap01.
if you search for this part in you default installation you will find also the excel that's used for this case.

Ruud van den Brand
Pre-sales NX CAD
cards PLM Solutions

Re: Trouble adding knowledge enabled part

Experimenter
Experimenter

Hi,

Trouble rarely come alone, my NX and Teamcenter licenses became outdated this morning. I will test both suggestion when i'm up and running.

Thanks alot for helping though! Smiley Happy