Cancel
Showing results for 
Search instead for 
Did you mean: 

Unhiding surfaces

Hi All,

 

I have samll doubt regarding unhiding surfaces.

Sometimes in an assembly file, part assembled may be a sheet body instead of solid body. So when I hide entire sheet bodies using CTRL+W, this part will also get hidden. But the part navigator shows part is visible. Even if I uncheck and Re-check again, the sheet body doesn't appear. Only way I knew this sheet body to bring back is to hide it from the background(CTRL+Shift+B). This is very difficult for large files where it would have numerous surfaces,bodies at the background. Otherwise I need to close the part body and reload at again. This is also not a good solution for me.

Situation is not same for solid body,when I re-check it will appear.

 

If you have any better ideas please share with me friends,

Thank you,

Dev.

 

5 REPLIES

Re: Unhiding surfaces

Legend
Legend

If you CNTRL-SHFT-K you can unblank selected. then pick through to the object you want.

 

In your component file, you can create multiple reference sets containing different items.

Rob Newcomb, CAD/CNC/Simulation manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.2 / Autoform r7 /WorkNC 2018 r2
Testing:NX EAP
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro

Re: Unhiding surfaces

Phenom
Phenom

To expand on what @R_Newcomb said about Reference Sets, use the Reference Sets command to define what objects are included in the Model Reference Set for each part you add to the assembly.

 

reference_sets.jpg

For example, for the parts where you want to display a surface in the assembly, add that surface to the Model reference set.

 

By being more deliberate about what should be displayed in the Model Reference Set for each component, you can display the Model reference set for all components in the assembly.

Then you won't have to manually try to show surfaces, and end up showing all surfaces for all the parts. 

 

 

Re: Unhiding surfaces

@MarkLawry,

 

Thank you,

That is a good solution I hope. But im not sure where im going wrong.!!!!!!!

Main assembly has 9 subassemblies among that one subassembly has surfaces and solid bodies.

I tried to include those surfaces into model using refernce set. However subassembly(3 surface bodies and a solid body each has model refernce set) did not get updated even after assigning reference set. It is showing only Empty and Entire Part configuration(Pictures attached).

One more thing I noticed there is no OK option when I added refernce set(It has CLOSE option,Simply pressed ENTER). Is that a wrong step?!!!!!!!!!!

 

Re: Unhiding surfaces

Phenom
Phenom

Ciao @Devraj_Mendon

Your initial question must be divided into several parts.
The reason why hide and unhide appear so strange is that the part in an assembly becomes a component with assembly specific properties. You can see this using the Wave Geometry Linker command with Hide Original selected.
In this case the component remains visible but not the solid body inside.

Hide.png

The Reference Set question is very complex and I try to give you some information that I hope will be useful.
There are only two default Reference Set: Entire Part and Empty, the third 'default' reference set, usually called MODEL, exists only if the appropriate field in Customer Defaults is filled and takes its name from it.
The entities highlighted in the figure will be placed in the Reference Set automatically.

refset.png

Try to change the MODEL name with another name, open a new part, check the reference set then create a solid body and check the reference set again.

refset1.png
Another factor that is often not considered is that associated with Assembly Preferences.

If Display as Entire Part is flagged when you set the part as Work Part, to extract geometry with the Wave Geometry Linker command, the solids and the surfaces extracted will not go into any Reference Set, while Display as Entire Part is not flagged, the solids and the surfaces will be placed in the Reference Set wich is active in that time.

preferences.png

Re: Unhiding surfaces

Experimenter
Experimenter

The bug persists even for solids. 

If I select a "component" to hide,  it will have use a "component" filter selection to unhide it. 

 

Likewise, if a component in an assembly is chosen as a "solid" in the selection filters to hide,  the same  "solid" selection filter has to be invoked to unhide it. 

You cannot use "Ctl_Shift_K" and just select the item to unhide. Or the from assembly layout either.  It will not reappear on the screen. 

 

It can be extremely frustrating when you hide certain items just to do a screen capture or check for functional clearances and have a hard time unhiding it later. 

 

Is there any good reason that its such on NX12?