Cancel
Showing results for 
Search instead for 
Did you mean: 

bug with expression?

Genius
Genius
Recently I'm facing a very annoying issue. Is this a bug? Thanks!
 
Image.pngget expression name   >>>   Image.pngcopy to clipboard
Image.pngedit value   >>>   image.pngtype "-", paste and press "Enter"Image.pngerror message
Image.pngok the error message, and type "-" and paste again, success
 
After this operation, pasting "p9_z" would not causing any error.
 
But if you change the "p9_z" expression to a new name, e.g. "p9_zz",  the first time pasting "p9_zz" would lead to the error message again.
18 REPLIES 18

Re: bug with expression?

Valued Contributor
Valued Contributor

why are you placing the "=" on the expression name ?

 

i tryed the file here and no problems :X maybe im doing something wrong

 

i usualy create all the variables separatly and got no problems on that

W10 - NX 9 - 10 - 11 - 12 - MW - Journaling || vegetagaru @ engtips

Re: bug with expression?

Genius
Genius

Hi @RomeuJanuario   Thanks! No, I didnot add "=" on the expression name. Sometimes the error occurs very frequently, sometimes it never occurs.

Re: bug with expression?

Valued Contributor
Valued Contributor

try a thing, when you rename the expression press "Enter", then apply, then try to paste it elsewhere and see if the error occurs

W10 - NX 9 - 10 - 11 - 12 - MW - Journaling || vegetagaru @ engtips

Re: bug with expression?

Genius
Genius

Hi @RomeuJanuario   I just tried "Enter" for rename. It doesnot help. Thanks!

Re: bug with expression?

Genius
Genius
And when I right-click the box, sometimes Edit never appears in the shortcut menu.
 
And double-clicking the box activates sometimes Rename mode, sometimes Value mode.
 
Image.png
 
Image.png

Re: bug with expression?

Valued Contributor
Valued Contributor

i just realized now where you are editing the expressions, does the same problem happens on the expression editor ?

 

any way i tryed in your file on the "details" tab renaming and its all ok, still i tryed on NX9 and NX 12, you are working with 11 right ? do you have latest MP and MR installed ?

W10 - NX 9 - 10 - 11 - 12 - MW - Journaling || vegetagaru @ engtips

Re: bug with expression?

Genius
Genius

Hi @RomeuJanuario   Thanks! It does not happen with the expression editor. My NX is the latest 11. I think that, if you start a new file and create two points from nothing, you should be able to reproduce the problem.

Re: bug with expression?

Valued Contributor
Valued Contributor

maybe the problem is that in the details tab the "update" its not "immediate"  and in case of renaming maybe in the details tab it dosnt force the variable where it is in use to update to the new name or something im not sure because i dont use at all the details tab, i allways go to the editor and if i want to edit expressions from a specific object i click on it and appears the expressions of the object. but its just my way, i will try to reproduce it here and tell you something

W10 - NX 9 - 10 - 11 - 12 - MW - Journaling || vegetagaru @ engtips

Re: bug with expression?

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

The issue is with the naming of the expression. The expression name becomes invalid if it contains any mathematical operators like "-" or "+".It is same for the expression dialog as well as the Part Navigator> Details.
While you try to double click or MB3>Rename in the Part Navigator details for a point co-ordinate and paste the value containing "-" in it,  the error is poped-up.