Cancel
Showing results for 
Search instead for 
Did you mean: 

changing decimal character input in NX12

Creator
Creator

Hello,

 

I would like to ask how to change decimal character input in NX12. I went from customer defaults all the way to annotation, where there is comma set as decimal character and comma is what is actually displayed in text and sketch values. But when I type number with comma, I can not enter it as system says I have syntax error in my input value as show in picture bellow.

Anyone any ideas how to deal with this?

 

Thanks,

David

 

Výstřižek.JPG

9 REPLIES

Re: changing decimal character input in NX12

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

If you are using a Windows system, I believe this is set in the computer's regional settings. These settings can be found in the control panel under the "clock, language, region" settings (or something similar depending on your version of Windows).

Re: changing decimal character input in NX12

Creator
Creator

This came to my mind as well, problem might be that I have english Win10 converted to czech...

Re: changing decimal character input in NX12

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

In the drafting preferences, you can set the decimal delimiter to either comma or period, which changes the display of the dimension, but I'm not sure it controls the allowed input. Drafting preferences -> dimension -> text -> units -> decimal delimiter.

Re: changing decimal character input in NX12

Creator
Creator

I know, that is what I did, comma was there set as default actually, but no change. Now I have problem with decimal places as well... no matter what number I set, it still displays only 1 decimal place and rounds the rest of the value

Re: changing decimal character input in NX12

Gears Honored Contributor Gears Honored Contributor
Gears Honored Contributor

When you make a change in the preferences, it only affects newly created dimensions; any existing dimensions will retain the settings used when they were created. If you make a new dimension and it only shows 1 decimal place, also check the "show trailing zeros" option. If, for example, your dimension is 0.200 and show trailing zeros is turned off, you will get 0.2 no matter the number of decimal places you have set.

Re: changing decimal character input in NX12

Creator
Creator

It is just not working, neither decimal character, nor decimal places. I do not know what I am doing wrong, but I am going to contact support, I have already lost a lot of time with this. Thank you for your effort though.

Re: changing decimal character input in NX12

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @David_Ryvol,

 

I found the same thing.  I changed my region to France and UGII_LANG and keyboard to French.  I created a blank millimeter part and attempted to create a block using 100,1 and got the syntax error.  I also tested NX 8.5 and got the same result, so it's not a regression in NX 12.

 

Please let us know if you're able to resolve the issue.

 

Regards, Ben

Re: changing decimal character input in NX12

Phenom
Phenom

As I understand this a decimal point is still a decimal point it is only the display format that changes.

 

For data entry use the decimal point on the keyboard to get the right syntax. It is only displayed as a comma.

Re: changing decimal character input in NX12

Creator
Creator

Yes I know, I am using dot instead of comma, but I was hoping this can be changed. It is quite annoying because I have comma at numeric keyboard and have to search for dot at alphabet keyboard all the time