Cancel
Showing results for 
Search instead for 
Did you mean: 

disable convergent modeling?

Legend
Legend

I moved to NX12 a week or so ago.

I started a new project, File open Catpart. Then proceed to make a prototype tool.

For this, I use mostly surfaces and somehow I've ended up with convergant facet bodies,   The blue surface is just an extrude, but somehow its a facet body. When I use the selection filter, everything is just sheets and faces no facets

 

Any suggestions?

facet.PNG

Rob Newcomb, Design and Engineering manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.2 / Autoform r8 /WorkNC 2020.0
Testing:NX 1855
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro
4 REPLIES 4

Re: disable convergent modeling?

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi  @R_Newcomb,

 

When you use any modeling command with Convergent bodies, output is Convergent body.

 

To resolve issue, invoke "Facet Body from Body" command -> Set output to "Convergent" -> Select NX curvy body -> OK. You'll get Convergent body. Now  both tool and target will be of same kind. So there should not be error.

 

Regards,
Samadhan

GTAC | NX Help: NX1102 | NX1202 | NX1847
Please mark post as an "Accepted Solution", if it answers your question/is more helpful!

Re: disable convergent modeling?

Legend
Legend
I didn't mean to create a convergent body, I don't have a need for it so I was hoping there was a way to disable the function in defaults.

I cannot even figure out How I made a convergent body from extruding curves in the 1st place, it's not an option

Luckily this was a small easy job, so I was able to recreate it correctly easy enough. I don't want to run into it on a job that I have multiple hours into
Rob Newcomb, Design and Engineering manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.2 / Autoform r8 /WorkNC 2020.0
Testing:NX 1855
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro

Re: disable convergent modeling?

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Rob -

Did you see this thread?

https://community.plm.automation.siemens.com/t5/NX-Design-Forum/extrude-from-face-edge-fail/m-p/4921...

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: disable convergent modeling?

Legend
Legend

Thank you for directing me to that

This seems like a very dangerous new "feature" as convergent bodies do not export via iges or step

Is there a way to search a model for convergent bodies?

 

I don't see a way to shut it off in customer defaults either.

 

Time for an IR.

 

Rob Newcomb, Design and Engineering manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.2 / Autoform r8 /WorkNC 2020.0
Testing:NX 1855
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro