Cancel
Showing results for 
Search instead for 
Did you mean: 

nx9 very slow sketch response when creating dimensions

Pioneer
Pioneer

Hello, I am using nx 9.0.2.5 with Daimler Add-on

When I try to create dimensions in sketch, it becomes incredible slow. After clicking first object, I have to wait several seconds to be able to select the second object. In the meantime the program is busy with message updating objects in the cue line. Sometimes a window with the title System is Working appears for a second. But I have to wait for the active cursor.

 

I didn't mentioned this before, when trying on small models. My current part is about 1GB size and the sketch is in 2/3 of the modeling history.

When in sketcher, all other geometry is hidden and the sketch is really simple, just few lines.

I am using 3D connection spacemouse pro, it's disconnection doesn't have any influence.

I never have seen something like this before in NX.

Is there any setting which causes this strange behavior?

Setting delayed sketch evaluation nor switching off the fixed text size didn't help.

 

In other situations, like solid modeling or surfaces, everything works well - no problem with response or graphics at all.

Regards, Pavel Jiricek

11 REPLIES

Re: nx9 very slow sketch response when creating dimensions

Phenom
Phenom

Are you doing an Edit, or an Edit with Rollback, on the sketch?  I would try Edit with Rollback, the model may be trying to update every little thing you do, to everything driven by the sketch.  With Rollback should delay those updates, until you exit the sketch.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: nx9 very slow sketch response when creating dimensions

Pioneer
Pioneer

Hello, thanks for response. It's not about updating the model. It seems like updating the sketch graphics is very slow.The longest busy time is after selecting the first object for the dimension. In that moment nothing is changed on the sketch geometry, nor on the model. I tried and both methods of editing the sketch do behave the same way.

Model is updated after I finish the sketch - and it needs some time, ofcourse.

 

Re: nx9 very slow sketch response when creating dimensions

Pioneer
Pioneer

There is still no solution to this problem.

Re: nx9 very slow sketch response when creating dimensions

Pioneer
Pioneer

Still no solution, I will report it to QTAC

Re: nx9 very slow sketch response when creating dimensions

Experimenter
Experimenter

Good morning Pajir,

 

Did you obtain a working solution from Siemens Support? Currently my design office faces same issue with NX9 customized for Daimler.

Version of NX is NX 9.0.3.4 MP2 D1, 13nov14

Bundle : AS5050

Daimler supplier package : Build4

 

Many thanks for your feedback

Mathieu

 

Re: nx9 very slow sketch response when creating dimensions

Legend
Legend

I have not tested this but have you tried turning on the delay model update under tools update?  Does this help speed things up a bit?  Just being curious.

Re: nx9 very slow sketch response when creating dimensions

Experimenter
Experimenter
Hello Sdeters, We have tried to turn on "Delay model update" unfortunately it doesn't work,we continue to face the issue nevertheless many thanks for your help.

Re: nx9 very slow sketch response when creating dimensions

Experimenter
Experimenter

Hello Gents,
any news on this topic ?

Any solutions?

 

I’m facing the same issue with NX10.0.3.5 for some (2-3 users).
the sketch response is really slow for them even in some small “dummy” design…

 


pajir wrote:

Still no solution, I will report it to QTAC


@ pajir, do you have any IR number, orany solution from QTAC ?


Thank you in advance for any help.

BR
Radek

Radoslaw POPOWICZ
Global CAD Admin | ITCAD/PDM | Sulzer

Re: nx9 very slow sketch response when creating dimensions

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Radoslaw

 

There were a couple of issues reported circa NX9 regarding the sketch response that was discussed in this thread.  In those cases unchecking "Apply Filter" in the Part Navigator resolved the delay.  Right click inside your Part Navigator and see if you have Apply Filter checked.

 

Regards, Ben