Cancel
Showing results for 
Search instead for 
Did you mean: 

".STP" inport error

Experimenter
Experimenter

Hello, I'm new to the forum!

 

I recently upgraded to NX8.5 from NX7.  SInce then I am not able to import ".stp" files.  The translator comes up then an error message "Translation did not complete" comes up.

 

I kept all the default options but still am not able to import.

 

Let me know what you guys think or need to help me out.

Attached is the log file I tried to import.  File would import ok in NX7.

 

Thanks.

7 REPLIES

Re: ".STP" inport error

Siemens Phenom Siemens Phenom
Siemens Phenom
Hello @RedChaser,

First thing that come to mind, since NX 8.5, Java is no longer shipped with NX. Did you set the variable: UGII_JAVA_HOME to your java directory?

Kind regards,

Dennis
Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: ".STP" inport error

Experimenter
Experimenter

Hi @DennisdeBrouwer,

 

I am not sure how to or where to go to do that.  Can you please tell me how to check that?

Re: ".STP" inport error

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

You need to check it (UGII_JAVA_HOME)  in your Environemnt variables.

Additionaly you can through this post http://www.eng-tips.com/viewthread.cfm?qid=329687 

It might be of some help to you.

Best Regards

Kapil Sharma

Re: ".STP" inport error

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

You can search through the NX log file. I looked through the one you posted and it isn't set.

 

Windows Control Panel -> System -> Advanced System Settings (Upper left) -> Environment Variables

 

Try and create a new variable (preferably system, but a user one will do if you don't have permission).

 

Variable name: UGII_JAVA_HOME

Variable value: C:\Program Files\Java\jre1.8.0_65

 

The folder for java, will be dependent on your system and where it's installed, but it has to be the 64bit version of Java as you are using the 64bit version of NX.

Anthony Galante, Senior Support Engineer
PhoenxPLM
24 versions of NX installed: NX4 to NX12, plus TC11.2

Re: ".STP" inport error

Siemens Phenom Siemens Phenom
Siemens Phenom
Sorry @RedChaser,

Missed your question. But Anthony has answered the question already.

Kind regards,

Dennis
Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: ".STP" inport error

Experimenter
Experimenter

Thanks @PhoeNX_Support,

 

I did do this and I was able to successfully do an STP import, but I was only able to do it thought the STP translator under the SIEMENS folder (see attached picture).

 

I still cannot import an STP file while in NX.  I still see same error.

Re: ".STP" inport error

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

have a look in the folder where you tried to do the export to.

there should be a translator log file.

I think you've now got the same error appearing but a different cause.

 

Anthony Galante, Senior Support Engineer
PhoenxPLM
24 versions of NX installed: NX4 to NX12, plus TC11.2