Cancel
Showing results for 
Search instead for 
Did you mean: 

scale lines and bodys

Creator
Creator

how i can scale lines and bodys at the same time in no uniform mode, i prove local scale, transform, and dont work...thx

8 REPLIES

Re: scale lines and bodys

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
so far i know there is no feature that will do both things in ones.
what you can do is make a expression that is used the both features so they have the same value.
also make sure that you use the same scale start point so the scaling will be the same.

Ruud van den Brand
Pre-sales NX CAD
cards PLM Solutions

Re: scale lines and bodys

Creator
Creator

It's a shame, thanx

Re: scale lines and bodys

Legend
Legend
I use the obsolete commands for scaling, you can grab everything and it even leaves the data on their original layers if you want to.

The old Transform command
Rob Newcomb, CAD/CNC/Simulation manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.2 / Autoform r7 /WorkNC 2018 r2
Testing:NX EAP
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro

Re: scale lines and bodys

Pioneer
Pioneer

I am trying to use the Transform command to scale up a small group of lines on a drawing (in Drafting, of course).  I can easily re-create the geometry at the increased scale, but I am trying to use this as a learning opportunity. I select "Transform".  Next, I select the objects and hit the OK button.  Then I select "Scale".  In the "Point Location" box, I select the desired point.  Then, when the Scale box comes up, I input a scale of 1.5 and hit the "OK" button.  I accept the defaults in the next box that comes up and hit "OK" again.  Then the lines disappear.

Can anyone tell me what I am doing wrong.  I would suspect this is a simple task to complete.  Thanks.

Re: scale lines and bodys

Legend
Legend

If you are using the "classic" transform command select move or copy, OK then cancel.

Rob Newcomb, CAD/CNC/Simulation manager
Elmhirst Industries, Specializing in Prototype sheet metal stampings and assemblies

Production: NX 12.0.2 / Autoform r7 /WorkNC 2018 r2
Testing:NX EAP
PC: Rave Cadbeast: Intel(R) i7-4790K CPU @ 4.GHz /32gb ram /NVIDIA Quadro P2000 on Win10 Pro

Re: scale lines and bodys

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Depending on the position of your objects and the point location chosen, the objects may have moved off of the drawing sheet; zoom out to see if you can locate them. Performing a "fit view" in this case won't help as it will fit the drawing sheet to the view and ignore objects beyond the drawing border. If you cannot find them, check the layers that are currently turned off (the scaled lines may have been created on a layer that is currently turned off). Make sure that the layer option in the final dialog is set to the layer you want.

Re: scale lines and bodys

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @DaveL3149,

 

Are you sure you're not changing the destination layer as one of your steps?

Your problem sounds very similar to the case where new objects are placed on the drawing sheet, on the work layer, and they disappear.  This occurs when the work layer of the drawing sheet has been set to 'Invisible' in the Layer Visible in View settings.

Go to "Menu > Format > Layer Settings" and note your 'Work' layer.

Go to "Menu > Format > Layer Visible in View > OK" and scroll through the layers to find the work layer.  Does it show "Visible" for the work layer?  If it's blank the work layer is invisible, so highlight the layer, select "Visible" and OK the dialog.

 

Regards, Ben

Re: scale lines and bodys

Pioneer
Pioneer

Thanks for all of the suggestions from everyone.  I learned some things in this process.

What solved the issue:

Originally I was selecting the items in a window, which identified 5 objects.  I then tried individually selecting the lines, which are 4 objects.  The command then worked.