Cancel
Showing results for 
Search instead for 
Did you mean: 

Default module when opening parts

Phenom
Phenom

I think I know the answer to this, but it might be worth asking anyway.

 

We are writing a number of automation projects (using NXOpen/Java) that we can execute either in a batch mode (ie run the jar as a standalone application) or interactively using RMI to connect to the users existing NX session.

The steps being taken involve opening an existing CAM part, then opening a Model part, switching to the CAM part and adding the model part as a component to the CAM part. There is a lot of other work going on as you might imagine so this sequence is fixed and just changing the order of opening the parts is not possible.

The problem we are seeing is that in batch everything works great. But when run interactively opening the CAM part first puts the NX session into the Manufacturing module, but then when the Model part is opened NX prompts for a CAM Setup because it is in the Manufacturing module and that part does not have a CAM Setup.

We don't want a CAM Setup in the Model part so is there a way to force NX to open the Model part in the module it was saved in instead of the current module?

Or is there some setting to prevent NX prompting for the CAM Setup when automation code is executing like it seems to do in batch?

 

Please don't get hung up on the RMI stuff, I can write a VB journal that opens some simple cam/model parts and executing that interactively displays the same behaviour.

Graham Inchley Snr R&D Engineer (Systems Development), Sandvik Coromant
Lenovo ThinkPad W540, Win7, 16GB. Developing in: Java | C | KF
Production: NX8.5.3.3 MP11 64bit Testing: NX9.0.2.5
4 REPLIES

Re: Default module when opening parts

Esteemed Contributor
Esteemed Contributor

I think the answer is no, since the interactive session is working much differently than a non-interactive one.

 

In a non-interactive session, you don't switch applications at all, so there is no trigger for the CAM setup.

 

Why do you open the CAD part after the CAM part interactively?

If you open the CAD part prior to the CAM part, you don't have the problem.

In addition using File => New and a template that references a model, the CAD part is automatically selected as the component.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX12.0

How to Get the Most from Your Signature in the Community

Re: Default module when opening parts

Phenom
Phenom
To be honest, I'm not entirely sure why the parts are opened in that order. I'm not actually working on that side of the project myself. I have a meeting this afternoon, so I'll ask for some more details.
In the meantime I came up with a workaround:
- Create a temporary part (no template or anything) and it opens in Gateway
- Open the CAM part, still in Gateway
- Close the temporary part
Seems to work OK.
Graham Inchley Snr R&D Engineer (Systems Development), Sandvik Coromant
Lenovo ThinkPad W540, Win7, 16GB. Developing in: Java | C | KF
Production: NX8.5.3.3 MP11 64bit Testing: NX9.0.2.5

Re: Default module when opening parts

Esteemed Contributor
Esteemed Contributor

You can as well disable changing the application on part load in the customer defaults.

 

There is a setting "Gateway => General => Part => Enter Application where File was last saved".

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX12.0

How to Get the Most from Your Signature in the Community

Re: Default module when opening parts

Phenom
Phenom

Nice one! I wondered if there was a setting to control this behaviour, but couldn't find anything.

I must say I didn't search very hard though (obviously) Smiley Embarassed

Graham Inchley Snr R&D Engineer (Systems Development), Sandvik Coromant
Lenovo ThinkPad W540, Win7, 16GB. Developing in: Java | C | KF
Production: NX8.5.3.3 MP11 64bit Testing: NX9.0.2.5