Cancel
Showing results for 
Search instead for 
Did you mean: 

Help! Getting a c++ error when running application using run_manged.

Valued Contributor
Valued Contributor

Hello All,

 

I am opening a certain number of parts in the assembly with an NXOpen program using NX run_managed.exe. I am facing this weird error on the very first part that is opened using the program for processing. Other parts are working fine in the assembly.

 

The error is:

DEsc Standard C++ exception caught. See system log for details problem

Standard C++ exception caught. See system log for details

 

Could this be to do with a Graphics Card Driver? I am having Nvidia GeForce GT710 on this system.

 

Thanks,

Shanmugam.K

 

 

8 REPLIES 8

Re: Help! Getting a c++ error when running application using run_manged.

Legend
Legend

@Shanmugam18 

 

you need to downgrade your graphics card driver!!

伊尔凡

Re: Help! Getting a c++ error when running application using run_manged.

Valued Contributor
Valued Contributor

@Irfan23 I did read about this in another forum but how do I figure out which version should I downgrade to? We recently upgraded the systems from Windows 7 to Windows 10 and also updated the Nvidia graphics driver.

Re: Help! Getting a c++ error when running application using run_manged.

Legend
Legend

Hello @Shanmugam18 ,

Look at the bottom of this page : https://www.plm.automation.siemens.com/global/fr/support/certifications.html

You'll have a link to an excel listing certified graphics driver.

Best regards,
Frédéric.

Re: Help! Getting a c++ error when running application using run_manged.

Valued Contributor
Valued Contributor

If this is NX11.0.2, you probably need to be on at least MP8.  MP7 and earlier have issues with Nvidia drivers over 390 I think, even if they are the Siemens recommended drivers.

 

The other option we used until we were able to upgrade from MP6 was setting Windows environment variable JT_OGL45=1.

Re: Help! Getting a c++ error when running application using run_manged.

Valued Contributor
Valued Contributor

@mx_scot That is something I should ask my IT to definitely try. I am currently at MP02. I will upgrade and keep you posted.

What does the Environment Variable JT_OGL45 do? 

I could not find any reference to this online.

 

Thanks,

Shanmugam.K

 

 

Re: Help! Getting a c++ error when running application using run_manged.

Valued Contributor
Valued Contributor
I did go over this @FLehn but I could not find my Graphics Card listed in there. Mine is not a Quadro series Smiley Sad

Re: Help! Getting a c++ error when running application using run_manged.

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@Shanmugam18 wrote:
I did go over this @FLehn but I could not find my Graphics Card listed in there. Mine is not a Quadro series Smiley Sad

None of the GeForce cards are officially supported.

Re: Help! Getting a c++ error when running application using run_manged.

Legend
Legend

Hi,

I agree with @cowski1. It does not mean it won't work but it means you're on your own when it doesn't (Siemens won't patch the software if you've got a trouble which is related to your CG).

 

Regarding the environment variable, it'll just force your graphic card to use OpenGL 4.5 instead of 4.6 (your card is compatible with 4.6 but the software isn't if I remember correctly).

 

Best regards,

Frédéric.