cancel
Showing results for 
Search instead for 
Did you mean: 

NX 10 interactive class editor: Java virtual machine error

Valued Contributor
Valued Contributor

Hello everyone,

 

I have NX10 and when i hit the IDE button for Knowledge Fusion, Nx throws an error message "Could not locate Java Virtual Machine Library"

 

I tried setting up my environment variables :

UGII_JVM_LIBRARY_DIR  = C:\Program Files (x86)\Java\jre1.8.0_77\bin\client

UGII_JAVA_HOME = C:\Program Files (x86)\Java\jre1.8.0_77

 

I am still getting the same error. (see attached image for the complete error message)

 

Please let me know if you have any suggestions!

 

2 REPLIES

Re: NX 10 interactive class editor: Java virtual machine error

Phenom
Phenom

I believe that you will need the 64 bit version of Java installed.

Re: NX 10 interactive class editor: Java virtual machine error

Valued Contributor
Valued Contributor

Yes! That solved the issue. It is so strange that you need to go and pick x64 version for Java. By default, the update installs 32 bit version.

 

I need to change my environment variables too:

 

UGII_JAVA_HOME = C:\Program Files\Java\jre1.8.0_77

UGII_JVM_LIBRARY_DIR = C:\Program Files\Java\jre1.8.0_77\bin\server