Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

NX 4 Print doesn't working

OS: windows 7 x64

Environment variable: UGII_SDI_SERVER_CFG_DIR = C:\nx4plot\plotters

We do:

1. File - Plot - Plot...

On Printer Tab

2. Choose Printer/Output Format: Plotter_HPGL

Printer Profile: penplot_profile_0

Output Options: Print to File

On Print Setup Tab

Paper: Custom Size 1400 x 4000 mm

Orientation: Portrait

Scaling: Actual Size, 100% if Actual

On Print Layout Tab

Default

On Queue Tab

Click "Print" and choose folder for our .hpg file, Save.

In "Queued Jobs" we can see new task(0 WaitingToRun (0 in Q) Plotter_HPGL Administrator_nx4.cgm) and this not be complited.  Smiley Sad

 

IN NX 8.5.3.3 and NX 11.0.1.11 we did the same thing and received a HPG file, but it doesn't open our HPGL-viewer. Smiley Sad

 

On old machines(windows XP x86 and x64) everything working alright.

 

Pls Help! Smiley Sad

18 REPLIES

Re: NX 4 Print doesn't working

There's some log files for the plotting process - somewhere.

See if you can find them & see what's up.

IIRC they would often appear as if several lines get glommed together on one line, so they're a bit tricky to read thru.

 

Ken

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX 4 Print doesn't working

This happens with all models, and with simple ones.
Can you help me find the log file?

Re: NX 4 Print doesn't working

In your NX syslog (Help -> NX Log file - or something like that - I don't have access to NX4 anymore)

Search for "SDI" - find the ENV variables with "SDI" in them.

Figure out which ones point to folders.

The plotter job logs will be in a subfolder buried under one of them.

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX 4 Print doesn't working

File %temp%\bps\User\pcName\job_0\logfile.txt, right?

 

Spoiler
4 Apr, 2017 14:33:22:BPS: SUBMIT_TIME
4 Apr, 2017 14:33:22:BPS: Job 0 Submitted
4 Apr, 2017 14:33:22:BPS: Sending bSec ...
4 Apr, 2017 14:33:22:BPS: Sending bPrintTo ...
4 Apr, 2017 14:33:22:BPS: Sending myFilename ...
4 Apr, 2017 14:33:22:BPS: Sending myModel ...
4 Apr, 2017 14:33:26:BPS: Sending myPlotter ...
4 Apr, 2017 14:33:26:BPS: Sending myProfile ...
4 Apr, 2017 14:33:26:BPS: Sending C:\Users\ADMINI~1.ID2\AppData\Local\Temp\Administrator_nx4.cgm ...
4 Apr, 2017 14:33:26:BPS: QUEUE_TIME
4 Apr, 2017 14:33:26:BPS: Job Ready to Run
4 Apr, 2017 14:35:05:BPS: Downloading logfile.txt ...

I not understand why "NX Print" stopped work on windows 7. In NX 8.5 that also doesn't working.: smileysad:

 

Re: NX 4 Print doesn't working

Maybe becouse NX4 is not certified for Windows 7?

Is there a reason you haven't upgraded NX?

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX 4 Print doesn't working

[ Edited ]

Ken_A wrote:

Maybe becouse NX4 is not certified for Windows 7?

Is there a reason you haven't upgraded NX?

Maybe. i checked on windows xp everything working. 

NX 4 used on old machines, with old software not supported on windows 7 and newer versions.

 

I opened file HPG from NX 4 in Text-editor and file HPG from NX 11, and I see difference.

For example NX4 file:

Spoiler
E%0BBP5,1;IP;DF;WU0;SP1;SC;CR0,255,0,255,0,255;PU
LT1,1.0,1;LT2,6.35,1;LT4,12.7,1;LT7,12.7,1;LT;
PW0.025,1;PC1,254,254,254;LA3,0;
PU 0,5;PD 0,0,5,0;
PU 94697,55995;PD 94697,56000,94692,56000;
IW65303,0,94697,56000;
PW0.125,1;PC1,0,0,0;
PU 75899,48507;PD 75899,7493;
PU 76582,7493;PD 76582,48507;
PU;
PG;

And from NX 11 file:

Spoiler
E%0BBP5,1;
PS133399,56000;
IP;DF;WU0;SP1;SC;CR0,255,0,255,0,255;PU
LT1,1.0,1;LT2,6.35,1;LT4,12.7,1;LT7,12.7,1;LT;
CO"SDI CGM HPGL Version 2.01.30 Date:04-05-2017";
PW0.025,1;PC1,254,254,254;
PAPU0,0PRPU0,5PD0,-5,5,0PU133394,55995PD0,5,-5,0PAIW26601,0,133399,56000;
PW0.225,1;PC1,0,0,0;LA1,4;LA2,5;
PAPU0,0PRPU132097,38419PD-104194,0PU0,-1736PD104194,0
PU-104194,-1737PD104194,0PU-104194,-1736PD104194,0PU-104194,-1737PD104194,0PU-104194,-1736PD104194,0PU-104194,-1737PD104194,0
PU;
PG;

You can see that in the file from NX 11 there are no delimiters and line breaks ( ; ), therefore this file not supported in our HPG to ISO utility.

 

Why that happen ? Can i customize this?

Re: NX 4 Print doesn't working

 Just guessing - the text file output from NX changed to UFT-8 encoding some time ago - maybe that is the issue? You could try using something like notepad++ to change the NX11 HPGL file to ASCII encoding, and see if that makes a difference. 

Mark Rief
Retired Siemens

Re: NX 4 Print doesn't working


MarkRief wrote:

 Just guessing - the text file output from NX changed to UFT-8 encoding some time ago - maybe that is the issue? You could try using something like notepad++ to change the NX11 HPGL file to ASCII encoding, and see if that makes a difference. 


Nothing changed. Can I configure ANSII encoding for NX Plot default?

Re: NX 4 Print doesn't working

Somebody can help?