Showing results for 
Search instead for 
Do you mean 
Reply

NX 9.0 install Error

Hello all,

 

I have just finished updating one of our laptops from NX 8.5 to NX 9.0, following the typical install process I have followed for all of our desktops (which were successful).  After complete the installation of NX 9.0 on the laptop, when attempting to open the new program I get the following Error message:

 

"NX license error: Cannot connect to the license server system.  The server (lmgrd) has not been started yet, or SPLM_license_server is set to teh wrong port@host.  [ -15]."

 

*This laptop uses a borrowed license* - Which has not been set up yet. 

 

Now heres the key point, If its directionly connected "Plugged in" to our newtork, it works great.  The program will start up quickly and with no issues.  If I switch it over to our WiFi or any other network connection, the program fails and this is when I receive the error message mentioned above.  Also, when directly plugged into our network, I have the option of license borrowing in the Licensing

Tool.  When of WiFi, the Licensing Tool displays "License Borrowing is Disabled"

 

Has anyone experienced this before? If so what light could you shed on me?

Looking forward to your responses.

 

Thanks,

 

Jake

Jake
6 REPLIES

Re: NX 9.0 install Error

What is the ENV variable SPLM_license_server set to?

Is there a (Flex) OPT file on the license server, if so what are its contents?

 

Note (I think) borrowed licenses are only available in the version they were borrowed in.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX 9.0 install Error

Assuming Ping is not turned off...

 

can you ping the license server when configured so NX works?

can you ping the license server when NX is not working?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: NX 9.0 install Error

"Note (I think) borrowed licenses are only available in the version they were borrowed in."

 

I believe you are correct, we will have to wait until the borrowed licesnse is returned. 

 

Although, we are now experiencing the exact same error message whith NX 8.5 which currently has the borrowed license. 

 

Any input is helpful. 

 

Thanks.

Jake

Re: NX 9.0 install Error

You can return the license early through the license options tool, where you borrowed the license with.

 

As stated before borrowed licenses are only available for the release they have been borrowed with.

We created a problem report regarding this issue, since it is totally different from the regular behaviour, but FlexNET won't change this.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: NX 9.0 install Error

Correct. 

 

The original issue was, I had updated a laptop from NX 8.5 to NX 9.0 in the middle of a license borrow cycle (ends 09/10/2016).  I needed to transfer the borrowed license from 8.5 to 9.0 (which we discovered could not be done).  In an attempt to return the borrowed license early, we continuted to be denied by the "license options" tool of NX 8.5.  After a few calls with GTAC, I was informed this could not be done on NX 8.5 and returning licenses early was not available on the earlier versions of NX. 

Although, now the issue is we are suddenly experiencing the exact same error message on NX 8.5 which was working properly, as we were on NX 9.0.  Error message: "NX license error: cannot connect to license server system.  The server (imgrd has not been started yet, or SPLM_LICENSE_SERVER is set to the wrong port@host."

 

I have seen multiple discussions of users with the same issues and no resposes or solutions.  This worries me, I am still awaiting additional information from GTAC regarding this matter.

Jake

Re: NX 9.0 install Error

I have returned borrowed licenses successfully with NX 8.5.3

Have you removed any entries in the registry?

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community