Showing results for 
Search instead for 
Do you mean 
Reply

NXOpen python 3.4 crash on Mac OS X Yosemite

Hi guy's

 

I am using NX10.0 on a mac. I executed the examples on java an it works good. But i am fan of Python and i tried to execute the demos in python with the journal. But then the X11 is crashing with the error :

(com.siemens.plm.nx.57968[15980]): Service exited with abnormal code: 1

 

Yes i changed the verson of python on my mac to 3.4, it was also crashing with the 2.7.

What is wrong ?

8 REPLIES

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

 

According to the Release Notes, the supported Python installation for NX10 is V3.3.2.

 

If using the supported version does not work, please log an IR with GTAC so we can investigate.

 

Thanks!

 

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

You say you execute Java code using NX10 on Yosemite. Are you running a Journal or a class/jar file? I ask because we are unable to excecute class or jar files in NX10...

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

Hoi Marcel,

 

I am executing jar-Files with the menu Point File-->Execute-->NXOpen and then choose the jar file. NX ist a little bitchy with the java version you must have Verion 1.8 and your compilance level of the jar file must be 1.8. Also jdk 1.8 must be installed on the mac.

 

 Set the /Applications/Siemens/NX10.0/ugii/ugii_env.dat file following parameter:

 

UGII_JVM_LIBRARY_DIR=/Library/Java/JavaVirtualMachines/jdk1.8.0_66.jdk/Contents/Home/jre/lib/server  [or whatever your version is mine is 1.8.0_66]

UGII_JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_66.jdk/Contents/Home

[or whatever your version is mine is 1.8.0_66 ]

 

that must work

 

 

Greets

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

Have you update to Yosemite or is it a new instaltion?

If you update you maybe have still installed java 6. Not say that you are working whit that. It is just still installed. Can you please check it?

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

it is a new yosemite from 01/2015 i have no jdk 1.6 installed i have only 1.7 and 1.8. installed

 

but i have a Problem with python not with java !!

 

Greets

 

 

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

This is whate the log says:

Loaded module /Applications/Siemens/NX10.0/ugii/libcaeinit.dylib 0x13c97b000 0x13c97b000

[ 1] 0x127515742

Error_Exception.cxx/UGS::Error::Exception:Smiley TonguerintTracebackToLog() (libsyss.dylib)

....

....

....

----- Error code  3600049 caught in file "/plm/cynas/ipbuild/ugnx100/build/sandbox/src/nxpythonldr/no/ind/python_loader.cxx" at line number 375

Unloading /Applications/Siemens/NX10.0/ugii/python/libpython3.3m.dylib

----- Error code  3600049 successfully handled and acknowledged

*** EXCEPTION: Error code  3600048 in line 379 of /plm/cynas/ipbuild/ugnx100/build/sandbox/src/nxpythonldr/no/ind/python_loader.cxx at Wed Oct 28 10:27:08 2015 CET

+++ Can't initialize Python

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

[ Edited ]

Sorry for hijacking your thread... i don't use python, i use java. Sadly there is not much testing from the Siemens side for OSX. You mabe have to wait years for solutions.Smiley Frustrated

Re: NXOpen python 3.4 crash on Mac OS X Yosemite

As suggested in the first reply to this thread, each of you should contact GTAC to get your configuration issues ironed out.

 

Marcel, in the future, please start a new thread for a new topic. Individual, focused topic threads help provide better, more concise search results for users with similar issues.