Showing results for 
Search instead for 
Do you mean 
Reply

Reuse library in Native

It's been a little while since I set these up for a native NX enviornment, and I'm not sure I have ever used the network path, instead of mapped drives.  In this case, not all users have the same mapped drives, so I want to use the network style path.

 

In the NX90env.dat file, I have:

NativeReuse=\\ncentfilsrv02\NX_Files\NX\HardwareLibrary

I can see it is set, when I check the NX log file.

 

In the customer defaults, site level, I have:

Test Hardware Library|$NativeReuse

 

The reuse library is displaying, but I'm not seeing anything other then the OOTB examples.  Will it not work with the network path?

-Dave
NX 11 | Teamcenter 11 | Windows 8.1
4 REPLIES

Re: Reuse library in Native

Update.  I think I finally got it to work, by creating a .krx file, and moving that to a location everyone could get to, and then putting that path in for the windows location, under Reuse Library Configuration File.

 

Sharing the krx configuration file, seems to be an easier way to setup reuse libraries, is that the common method now?  I see in NX11 you can actually export out the krx to a location.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Reuse library in Native

i decided to give up on the KRX method, and go simply with the native directory method, for consistency with the Teamcenter method.

 

Now, even though I did this at the site level, I can't see the libarary in the Reuse Library, but everyone else can.  I've restarted my NX session multiple times.  I'll bet if I restart my computer it will show up, but this is odd.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1

Re: Reuse library in Native

 Do you have a user or group level folder set?

If you do, that is over-riding the site level default.

 

I.e. you only get ONE level for folders (site OR group OR user level, last one "wins"), not the sum of "Site + group + user" folders

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Reuse library in Native

Took a look, and I did have a directory listed, looks like a default OOTB one, so I removed that, so there is nothing at my user level.  There is no group settings, and Site only has this main library, which I still do not see.

 

Time to restart the computer, and see what tomorrow brings.

-Dave
NX 11 | Teamcenter 11 | Windows 8.1