Showing results for 
Search instead for 
Do you mean 
Reply

libPart

So i am trying to run my application from the .exe

And i get an error saying that it can't load "dll libPart".

ANy idea what this is or what it is referring ti. It runs fine within visual studio, but not when i run it with the executable

7 REPLIES

Re: libPart

Is %UGII_ROOT_DIR% included in the PATH environment variable of the executing process?

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: libPart

Where exactly would I need to add that line of code?
CONFIDENTIALITY WARNING: This email communication and any attachments contain privileged and confidential information intended only for the use of the intended recipient. If the reader of this communication is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution, use or reproduction of this communication or its attached contents is prohibited. If you have received this communication in error, please notify us immediately by return email and delete this message and any attachment from your system.

Re: libPart

It is not to be added to the source code, it is the environment the process is running in.

 

In a batch script you would prepend the NX root folder to the PATH variable and run your executable.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: libPart

 

Try running your EXE in an NX Command Prompt - it should have the PATH defined properly.

 

To get one of these, pick Windows Start -> NX # -> NX Tools -> NX Command Prompt

 

Also be sure you have copied  ...ugii\managed\NXOpen*.dll into the same folder as your .EXE.

Re: libPart

Yes it worked properly from the command nx command prompt, can we set something so that we don't have to go through the command prompt everytime?
CONFIDENTIALITY WARNING: This email communication and any attachments contain privileged and confidential information intended only for the use of the intended recipient. If the reader of this communication is not the intended recipient, or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution, use or reproduction of this communication or its attached contents is prohibited. If you have received this communication in error, please notify us immediately by return email and delete this message and any attachment from your system.

Re: libPart

The only thing the "NX Command Prompt" does is source %UGII_ROOT_DIR%\ugiicmd.bat

 

If your script does that before anything else, the appropriate environment should be set up.

Re: libPart

 

Yes, you can.  First find your "ugii" folder.  If you don't know where this is, look in a syslog while NX is running, and search for UGII_ROOT_DIR.

 

Next go to Control Panel -> System -> Advanced system settings -> Environment Variables, and scroll down until you find PATH.  Highlight PATH, and pick Edit.

 

In the value field, paste your entire definition of the ugii folder onto the front of whatever is there, and then put a semicolon after what you paste in.