Cancel
Showing results for 
Search instead for 
Did you mean: 

16=Please help as I cannot get 3D animation to work and cannot setup MU paths

Genius
Genius

Hi good people,

Tried the DIY method (P/S Forum, P/S Help and online tutorials) but have come unstuck.

3D animation - trying to use a Steffen post, using onEntrance method - modded this to point the object to my 3D object - both the Robot KUKA, and as below, the OperatorSittingMale - but no luck with either - same error, SimTalk could not find the Robot_KUKA or the operator?


Regarding the MU animation, I can add an animation path as 2nd image below, but attempting "MU" or "Robot KUKA" in the Animation Object field yields no result - simulation runs fine, but no animation of MU or objects at all.

With thanks in advance,
16=3D Animation issues 01.Gif

 

16=3D Animation issues 02.Gif

5 REPLIES 5

Re: 16=Please help as I cannot get 3D animation to work and cannot setup MU paths

Phenom
Phenom

Here's an example of selfdefined robot axis animations

 

including method code to run the animations.

 

 

https://community.plm.automation.siemens.com/t5/Plant-Simulation-Forum/Change-3D-animation-and-graph...

Re: 16=Please help as I cannot get 3D animation to work and cannot setup MU paths

Genius
Genius

Thanks a lot simulator - will work through this in detail Smiley Happy

Re: 16=Please help as I cannot get 3D animation to work and cannot setup MU paths

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

only some remarks: there are two different types of animation possible

 

a) MU animation

 

this is running automatically, if a MU enters the Object; Plant Simulation plays the animation with the name default then; so your animation is on the wrong place

 

b) self animation

This animates the object itself (e.g. you rotate the SingleProc). Here you need to define your animations.

 

 

Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net

Highlighted

Re: 16=Please help as I cannot get 3D animation to work and cannot setup MU paths

Genius
Genius

Thanks Steffen,

I also had problems defining the path of the MU in the 3D view too - will return to that once I have got the object to animate.

Simulator - am still figuring out if the standard plantsim .JT objects will behave like your 6 DOF robot actuator. Maybe just the KUKA robot, the rest seem to be static 3D images.

Re: 16=Please help as I cannot get 3D animation to work and cannot setup MU paths

Phenom
Phenom

The 3D robot axis structure (animation objects a0..a6) was manually set up in the following way:

 

- hierarchical axis structure

- axis offset

- axis orientation

 

The axis graphics were cut out from the origin jt graphic

 

and pasted into the corresponding animation object (a0..a6)

 

Then the axis graphics were aligned to the axis origin.

 

With exception of ( maybe) the hierarchical structure, this set up data is not stored in the jt file

 

but can be stored in an exported s3d -file

 

or -with the 2d object counterpart- in an exported obj-file.

 

 

 

Unbenannt.PNG