Cancel
Showing results for 
Search instead for 
Did you mean: 

3D MUs disappearing

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

I created a singleproc in 3D with a lift. As the MU enters it should sit on the lift, move up or down and then be placed in the assembly. The MUs are not visible once they enter the lift but become visible once they enter the assembly. Why?

3 REPLIES

Re: 3D MUs disappearing

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
Hello Looby,

This is due to the lack of an MU animation path on the singleproc. If you want the MU to be visible on the lift, there should be an animation path defined for this. I think you can also program this like you programmed the animation for the lift, but I am not certain on this.

Best regards,

Nick Peeters
cards PLM Solutions
Nick Peeters
Simulation Consultant
www.cardsplmsolutions.com

Re: 3D MUs disappearing

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
I did some additional searching and saw you already put an animation path on the 'Lift' object and made this the animation object for the Singleproc. In this case, the only thing you need to do is name the Animation path on the 'Lift' object 'Default', instead of 'Normal'. This is the go-to name for default animations and then you won't require any simtalk, it should just work out of the box.

Best regards!

Nick Peeters
cards PLM Solutions
Nick Peeters
Simulation Consultant
www.cardsplmsolutions.com

Re: 3D MUs disappearing

Solution Partner Experimenter Solution Partner Experimenter
Solution Partner Experimenter

Thank you. I have just put that in and it has worked.