Cancel
Showing results for 
Search instead for 
Did you mean: 

AttributeExplorer for analog values

Legend
Legend

Hallo,

 

I like to use the AttributeExplorer to show the status of a transporter battery charge.

Attached is a transporter/battery loading example setup by Steffen B.

The status of digital objects is updated, the analog ones are not.

 

 

Best Regards

Marco

 

7 REPLIES

Re: AttributeExplorer for analog values

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

it doesnt work with the AttributeExplorer, but you can use a dummy object with display panel, here you can access all attributes

You only need to switch off the panel if you reset the simulation and switch on the panel in the init again (afer creating the transporters)

Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net

Re: AttributeExplorer for analog values

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello Marco,

 

the issue is that some of these attributes are non-watchable, so the attribute explorer won`t display them. A workaround could also be using displays, attached is your model where that is done so.

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution


Re: AttributeExplorer for analog values

Legend
Legend

Hi Steffen,

thanks for your reply and suggestion.

However I cannot find where the SingleProc 'd' is linked to the status of battery charge of the transporter.

I spend quite some time. There is nothing in the tab of the object instance, the SingleProc in MaterialFlow is not changed.

There is nothing in the Init resp. reset methods (I see the handling of the 'active' property only.

I can not access this line (grey out). When I click on the 'd' this status line does not grey out.

 

Regards

Marco

 

Re: AttributeExplorer for analog values

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

right mouse click on d - edit display panel

double click on the lines of the table in the display panel dialog

Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net

Re: AttributeExplorer for analog values

Legend
Legend
OK, thanks. Now I see...
I have never been in the Edit panel.

Best regards
Marco

Re: AttributeExplorer for analog values

Legend
Legend

Hi Igor,

 

thanks for your suggestions/workout.

To summarize the displays are dis-activated in the 'Reset' method, they are activated in the entrance control of the 'Source'.

I just have an issue when I apply this to my model.

I do similar, however my displays change from the display icon to (?) when I start the simulation.  So I need to stop the simulation, double-click on each display and press 'apply'.

 

Best regards

 

Re: AttributeExplorer for analog values

Siemens Phenom Siemens Phenom
Siemens Phenom

They change to (?) as when you start the simulation, your transporter is not instantiated yet in your frame, so the display has a reference to a not existing object. Another workaround that would keep all methods encapsulated in the displays and make them work after every restart is implemented in the attached model.

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution