Cancel
Showing results for 
Search instead for 
Did you mean: 

Error when opening the model - incorrect method

Siemens Pioneer Siemens Pioneer
Siemens Pioneer
Hi All, when opening the Plant Sim model, I get a notification that some of the methods I use in my Line (Oven) are incorrect; I am using relative path in the Line control - anyone has got an idea why this error occurs and what I need to pay attention to? thank you What the method is doing, is setting the variable to the MU name that is entering the Line. I have similar methods for other objects, where no error message pops-up, but the Line does not seem to "like it".
5 REPLIES 5

Re: Error when opening the model - incorrect method

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hi Irina,

 

Can you post one of the methods that is mentioned in the error report?

 

Regards,

Gert Nomden


Gert Nomden
Senior Consultant | Tecnomatix Product Manager
cardsplmsolutions.com

Re: Error when opening the model - incorrect method

Siemens Pioneer Siemens Pioneer
Siemens Pioneer
is do OvenName:=@.name; end;

Re: Error when opening the model - incorrect method

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hi Irina,

 

I could not reproduce the error in a mini-model. But are you sure there is a variable OvenName that can be reached by the method?

 

Gert


Gert Nomden
Senior Consultant | Tecnomatix Product Manager
cardsplmsolutions.com

Re: Error when opening the model - incorrect method

Siemens Pioneer Siemens Pioneer
Siemens Pioneer
Yes, I looked at a mini-model attached and the error is not there when closed and re-opened the model. I wonder how I can debug my big model to get rid of the notification. What's the efficient way without rewriting the whole frame/model and methods...please?

Re: Error when opening the model - incorrect method

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hi Irina,

 

Personally I would open the original method and re-apply changes so that the code is checked again by the software, then save and reload the model. If that does not help I would send it to GTAC unless someone else has a suggestion.

 

Regards,

Gert Nomden


Gert Nomden
Senior Consultant | Tecnomatix Product Manager
cardsplmsolutions.com